I had a scare last... - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-29-2009
Member
Thread Starter
 
Join Date: Feb 2008
Location: unknown
Posts: 890
I had a scare last...

Ok. Last night I had an evil scare. I now know what my heart tastes like after this. As you all know I'm on my 4th engine this year. And on my way home from work the check engine started flashing on and off. I said WTF?! The bad thing about it was that I was doing 70 MPH on interstate and the thought went thru my mind, Jesus not again. It stopped flashing 2 miles down the road. So just a few minutes ago I plugged in my scanner and got a P0305 Cylinder #5 misfire. That explains alot to me as to what is wrong with this friggin engine. So when I get paid, New spark plugs and plug wires will be installed and if possible a new ignition coil may be in the works. That should fix it shouldn't it?
Reply With Quote
  #2  
Old 12-29-2009
Jp7's Avatar
Jp7 Jp7 is offline
Member
iTrader: (9)
 
Join Date: Sep 2007
Location: My LED lab or on the dyno
Posts: 2,970
I had a wire just jump off a plug and threw a p0302 in my 2.3 not too long ago. I pushed it on and problem went away. Why don't you investigate and see what was causing the problem before you spend money. You already know its number 5, and that's the hardest part. If you've got a constant miss you should be able to feel it in vibration, as first and second order engine movement won't be balanced at all.
Reply With Quote
  #3  
Old 12-29-2009
Member
Thread Starter
 
Join Date: Feb 2008
Location: unknown
Posts: 890
Quote:
Originally Posted by Jp7 View Post
I had a wire just jump off a plug and threw a p0302 in my 2.3 not too long ago. I pushed it on and problem went away. Why don't you investigate and see what was causing the problem before you spend money. You already know its number 5, and that's the hardest part. If you've got a constant miss you should be able to feel it in vibration, as first and second order engine movement won't be balanced at all.
that's what I'm investigating. The scanner is just a pointer and it gets me looking in that area and look at possible options/solutions. I did find a loose plug wire and installed it back and it did nothing to fix it. It still misses from time to time. I'm thinking that it could be the plug wires and plugs because I'm pushing nearly 90K miles and those are still the same plugs,plug wires, and ignition coil from when I first got the old ranger. All that the Ford dealer did was transfer the factory parts to the new engine. Which was a 50K salvage motor out of another ranger. It misses pretty frequently and it's eating gasoline pretty bad too. I'm also looking at the fuel system too. It may need some Seafoam injector cleaner.
Reply With Quote
  #4  
Old 12-29-2009
Ngabr1's Avatar
Member
 
Join Date: Oct 2008
Location: CT
Posts: 483
Quote:
Originally Posted by knightmare1015 View Post
Ok. Last night I had an evil scare.
you mean like a nightmare?!?!

haha j/k dude. In all seriousness I hope you get everything straightened out.
Reply With Quote
  #5  
Old 12-29-2009
Member
Thread Starter
 
Join Date: Feb 2008
Location: unknown
Posts: 890
Quote:
Originally Posted by Ngabr1 View Post
you mean like a nightmare?!?!

haha j/k dude. In all seriousness I hope you get everything straightened out.
Thanks man. I thought that would be a little humorous. The man I talked to at autozone today was pretty informative about what I can do to fix this problem. This all happened last night when I was between 2 oversized 18 wheelers hauling mobile homes.
Reply With Quote
  #6  
Old 12-29-2009
Tys 4x4 FTW's Avatar
RF Veteran
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
kick her in the stomach and throw her down the stai...


oh. a truck scare.


carry on.
Reply With Quote
  #7  
Old 12-29-2009
Ngabr1's Avatar
Member
 
Join Date: Oct 2008
Location: CT
Posts: 483
lmaoo
Reply With Quote
  #8  
Old 01-01-2010
Member
Thread Starter
 
Join Date: Feb 2008
Location: unknown
Posts: 890
I got the plugs...

I got the plugs today. $28.00 bucks for 6 Spark plugs and a can of seafoam. next payday I'll be getting the plug wires. I got the Ford Motorcraft fine wire platinum tip plugs at adavnced auto. The cat told me that basicly They're the same as Autolite and they're made for Ford Motor Company by Autolite. I didn't get the Iridums. Some ***** there tried to get me to purchase some racing plug wires and he didn't know crap from apple butter. What's the point of getting racing plug wires to use with a stock ignition coil pack I tell him. I also told him to get lost. That's a good way to destroy an ignition coil. If I wanted to run racing plug wires there's 2 places to get a new ignition coil: www.underdogperformance.com or Redirecting... . If I went with the MSD ignition coil I'd have to get an adapter which will put the grand total over $400.00 bucks. This engine might be going into either a 1923 T bucket, or mom's old 2002 Dodge Neon which will take alot of work.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Took the ol girl out in the snow wheeling trip today with a nice scare...56k no way dixie_boysles Snapshots 44 01-08-2011 12:12 PM
Had a realistic Dream about my First Ranger last night. HAZZARDJOHN General Ford Ranger Discussion 7 01-27-2010 11:59 AM
had a little fun in the snow last night Downey Snapshots 15 01-28-2009 08:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:41 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.