Is my engine completely broke!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-18-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
Is my engine completely broke!!!

Well I was about 100 miles away from my house on my way up to NH. I had earlier that day changed out the thermostat and added a little stop leak because well I could smell antifreeze so I figured I had a leak and my temp gauge was going up and down every so often.

Well the begging of the trip the truck was running like a top, ran great. Then i stopped off at a rest stop and turned it off started back up on the highway and about 1 mile into it the truck started to develop a "tick tick tick" and it was related to the engine. I'd never heard it before this so I just kind of shrugged it off unti lit started to get louder. So I say to myself "when i get over this hill I'm going to pull over and check it out". Well a huge power lose in my truck started to happen, so I just pulled over right there and then and the power to the truck just cut off completely. Smoke was pouring out of the hood right where the thermostat is, and the resivour is filled with water and some of that stop leak came out of it.

I went out and the crank turns so I'm guessing its a huge head gasket leak....or well better said as BLOW OUT!!! I'm not sure what to do, the truck is a complete fubar right now.
Reply With Quote
  #2  
Old 10-18-2008
john93rangerstx's Avatar
Member
 
Join Date: Mar 2008
Location: WARWICK RI
Posts: 895
sezed the warter pump that stop leak will do that
Reply With Quote
  #3  
Old 10-18-2008
pacodiablo's Avatar
Member
 
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
The stop leak may have clogged something up and kept coolant from flowing.

Sounds like you will be taking the heads off...
Reply With Quote
  #4  
Old 10-18-2008
Ray_Welder's Avatar
Member
 
Join Date: Jan 2008
Location: Zephyrhills, FLorida
Posts: 1,037
Never use stop leak!!!

My dad put stop leak in mine once, and we eventually had to replace the radiator because it was about half clogged up. And when the head gaskets went bad, When I replaced them, most of the passages in the old gasket were clogged with stop-leak.
Reply With Quote
  #5  
Old 10-18-2008
JoshK's Avatar
Member
 
Join Date: Sep 2006
Location: CC, Indiana
Posts: 3,832
Did you put the thermostat in upside down?
nm you wouldnt have made it that far.
Reply With Quote
  #6  
Old 10-18-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
No I put it in the right way. It was running fine. I'm just upset because I have a new job next week. So today I'm going to out to look at something new. Not brand new but with less miles. Part of this new job is to have something thats reliable and my truck just isn't anymore. I'll end up taking it off the road and pulling the heads and everything and seeing what I can do when I have a chance.

I'm going to look for a new car for me, and a new one for my parents (there concorde is at probably 170,000 miles). and then they can buy a new truck.
Reply With Quote
  #7  
Old 10-19-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
Well the engine isn't siezed. It still turns over. but it won't fire. the water pump pulley still turns also. I'm not sure whats going on. I'm going to get a code reader today or tomorrow. I have to call out of work tomorrow but I'm going to end up dropping off my father and brother and then heading out to a dealership to see about getting a car. I was looking at either an 04 mustang or an 06 accord, I also wanted to check out a 03 ranger with a 4.0L but it was closed yesterday and isn't open today.
Reply With Quote
  #8  
Old 10-19-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
good luck with whatever you end up doing. It really is a sh!tty situation when your DD/your baby takes a big crap on you like that.


I ended up driving 5mi with immediately noticed power loss, assumed it was still warming up. Then.....the truck just died, in gear coming down a hill with no throttle. pulled over. noticed a nice fat old in my block. gotta love 305's. lol.
Reply With Quote
  #9  
Old 10-20-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
Yeah, I tell everyone I'll see my baby girl rot in my yard before I see her in the hangs of someone else. I'm going to check out the laws in CT and see what I can do.

So far its between a 4BT or a 5.0L. Or maybe a new 4.0 SOHC depending on the laws. I can't put another 3.0L in there.
Reply With Quote
  #10  
Old 10-20-2008
JRacer's Avatar
Member
iTrader: (2)
 
Join Date: May 2008
Location: Watson, Louisiana
Posts: 1,085
Go 4.0
Reply With Quote
  #11  
Old 10-20-2008
john93rangerstx's Avatar
Member
 
Join Date: Mar 2008
Location: WARWICK RI
Posts: 895
:move to rhode island ill get it to pass sombrero:
Reply With Quote
  #12  
Old 10-20-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
ha ha ha. Well I bought a scan tool today for any OBDII vehicle and its not throwing any codes.
Reply With Quote
  #13  
Old 10-21-2008
CBFranger's Avatar
Member
 
Join Date: May 2008
Location: Tampa Bay Area
Posts: 1,029
Check your oil. If it is milky it is probably the head gasket.

Otherwise, that stopleak stuff may have clogged the wrong holes.
Reply With Quote
  #14  
Old 10-21-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
No the oil doesn't look milky or even low. no bubbles.
Reply With Quote
  #15  
Old 10-21-2008
Member
 
Join Date: Feb 2008
Location: unknown
Posts: 890
Under the dash on the passenger side is a huge red button. Push and hold it in for a few seconds. It should fire up. That stop leak aint worth a damn. Try it and see. When my fuel pump was about to go out it done exactly what yours did. I ended up getting a new fuel pump and Fuel safty shut off switch.
Reply With Quote
  #16  
Old 10-22-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
Ok, I'll give it a look see. Thanks.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I'm completely lost Trigger_Happy SOHC - 2.3L & 2.5L Lima Engines 31 02-05-2009 05:12 PM
K & N FIPK completely F'ed my MAF sensor. Diltzy 4.0L OHV & SOHC V6 Tech 12 10-22-2008 07:46 AM
Completely white screen? NEED HELP! Oh5Edge Audio & Video Tech 0 04-01-2008 04:59 PM
My truck is getting completely overhauled ! EricTodd General Ford Ranger Discussion 59 05-04-2007 06:15 AM
What happens when a wheel bearing fails completely? FMD General Ford Ranger Discussion 33 12-29-2006 01:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:51 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.