mysterious squeal. please help! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-25-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
Icon4 mysterious squeal. please help!

So i will start off at the beginning. it all started when i had a belt squeal, and i had to replace the tensioner due to the spring assembly being loose, and cocking the pulley off to one side, and the belt hitting it at an angle. the squeal only happened when it got wet or moisture was present. it eventually got to the point to where it would always do it. i replaced the tensioner and now its grand. now i have a mysterious squeal, with similar characteristics. it only does it when it gets wet, moist, or the day after a good rain storm. and it starts to squeal when the motor reaches 1500 rpm's, no matter what load, what gear, or what position the clutch is in. i thought it was coming from the motor, llike maybe an altenator, but it honestly sounds like its coming from under the truck, or if you put your head right over the center of the motor, it sounds like its coming from the back of the motor near the firewall. i have been trying to fix it and figure it out now for about a year. it dosent get worse, it goes away and only comes back when it rains. i have replaced the water pump, belt, tensioner, idler pully. honestly if you listen from the front of the truck, or under the hood its hard to hear. but if your in the cab with the door open or off to the side of the truck, its clear as day. so if anyone has an idea, please help!
Reply With Quote
  #2  
Old 07-25-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
also, this may or may not be related, but it also has a wierd chatter at or up to 1500 rpms, that always happens. sounds like just normal motor noise, but it may be related
Reply With Quote
  #3  
Old 07-25-2012
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
Cam position sensor is going bad. It sits passenger side back towards the firewall.
Reply With Quote
  #4  
Old 07-26-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
how hard is it to replace? and how much is the part about?
Reply With Quote
  #5  
Old 07-26-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
And if possible could someone explain how this part works, and why it's squealing? I looked at the part online and it looks like it has no moving parts, but I have heard of this part causing this. Just never knew how
Reply With Quote
  #6  
Old 07-26-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
Ok update: it's not the camshaft pos sensor, it's the camshaft synchronizer. All the sensor is is a car with a piece of metal and a plug. The synchronizer is the assymbly with the bushings. But 61 dollar fix. And it comes with a cap and the tool to Put it in.
Reply With Quote
  #7  
Old 07-26-2012
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
Quote:
Originally Posted by rangerstepside View Post
Ok update: it's not the camshaft pos sensor, it's the camshaft synchronizer. All the sensor is is a car with a piece of metal and a plug. The synchronizer is the assymbly with the bushings. But 61 dollar fix. And it comes with a cap and the tool to Put it in.
yeah its easy to do. there is a how-to on here that justin made a while ago
Reply With Quote
  #8  
Old 07-27-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
From what I hear it is like a distributor. So it's gotta be put in carefully, but the One I got has A cool cap on it that has an arrow with a built in tool to line stuff up
Reply With Quote
  #9  
Old 07-28-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
btw in addition to the thread, i know this part is the weak spot on the motor. is this the one part along with the sensor that solves this problem?
Reply With Quote
  #10  
Old 07-29-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
Replaced the synchro. Took the squeal away along with a weird chatter. Runs sooooooo smooth!
Reply With Quote
  #11  
Old 07-29-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
ok scratch that, squeal came back. only for a mile or so. then went away. so i replaced the alternator, just to see. hasnt come back yet so i think the synchro was breaking in? oh well seems to run better.
Reply With Quote
  #12  
Old 08-04-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
ok squeal is getting worse, i believe its a pilot bearing but i dont know what else could squeal like that
Reply With Quote
  #13  
Old 08-11-2012
Member
 
Join Date: Aug 2012
Location: Rolla
Posts: 1
This link takes you to a you tube video showing how to replace the cam sycnhro step by step
Reply With Quote
  #14  
Old 08-20-2012
Member
 
Join Date: Jun 2012
Location: ashford ct
Posts: 8
could also be an idler pully its a ford thing
Reply With Quote
  #15  
Old 08-20-2012
Member
 
Join Date: Jun 2012
Location: ashford ct
Posts: 8
its an idler pully im almost 100% postive 50$ fix or dont worry about it
Reply With Quote
  #16  
Old 08-24-2012
rangerstepside's Avatar
Member
Thread Starter
 
Join Date: Nov 2010
Location: eafb, sd
Posts: 545
It was a pilot bearing. Got a whole new clutch while I was in there. Bought an hd clutch. Love it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Sudden mysterious vibration - Please Help! KevinOK General Technical & Electrical 0 07-03-2013 11:23 AM
mysterious leak??? 02rangermayhem 4.0L OHV & SOHC V6 Tech 20 01-28-2010 05:25 PM
Leaking Coolant - Mysterious Leak highland04 2.3L & 2.5L I4 Tech 5 08-22-2009 11:47 PM
mysterious engine squeek - NOT pulley related therangerofdanger 2.9L & 3.0L V6 Tech 4 04-11-2008 06:00 AM
mysterious little warning chime Hot Mama General Technical & Electrical 3 03-07-2008 07:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:32 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.