Problem - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-28-2007
sonic_blue_tremor02's Avatar
Member
Thread Starter
 
Join Date: Apr 2006
Location: Ketchum,Ok
Posts: 80
Problem

Hey everyone..its been a while since i have been on here..well any way the other day i started my truck and it started then it started shaking and the engine juddered i thought it was because i needed gas and its done that before when i was low on gas..so i put gas in it. and i continue driving and my check engine light came one and it started juddering again...any ideas??
Reply With Quote
  #2  
Old 12-30-2007
Member
 
Join Date: Dec 2007
Location: Taylorsville Ky
Posts: 289
Have you tried cleaning the IAC valve? That seems to cause a lot of idle and dying at take off problems. If it helps it you may have to replace it to really fix it for good. I need one for my Aerostar and it's about $65.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 06:58 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:16 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.