rough idle not CEL - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-14-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: london
Posts: 21
rough idle not CEL

so I have a 2001 edge 3.0 and it seems to idle a little bit rough. It never stalls and the CEL never comes on but it shakes a little bit and surges up and down. I have changed spark plugs, wires, fuel filter, cleaned the TB, IAC, and about to clean the MAF. Any other ideas? Would I be better off just buying a new IAC and possibly and EGR valve?

thanks
Reply With Quote
  #2  
Old 04-14-2011
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
had my iac cleaned before i traded in the ranger

turns out my iac was jammed open from the k+n filter oil drying out and particles flowing into the iac port

hence my partially rough idle
Reply With Quote
  #3  
Old 04-14-2011
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
watch videos on youtube about IAC. JUST figures out mine is bad and will be cleaning it Tomorrow morning
Reply With Quote
  #4  
Old 04-16-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: london
Posts: 21
ok well I have cleaned the IAC but it still idles a bit rough. so I think I`ll go out and get a new one and hopefully that solves the problem.
Reply With Quote
  #5  
Old 04-19-2011
Member
 
Join Date: Mar 2011
Location: Decatur, AL
Posts: 2
After cleaning everything, changing the plugs and wires and beating my head against concrete, I found a vacuum leak, driver's side rear of engine, on the PVC hose. It wasnt split, it had a small leak between the rubber and plastic, and the grommet holding the PVC in was also leaking. Some cleaning, zip ties and it runs like new.....
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
Rough engine idle but not misfiring bubba3689 General Ford Ranger Discussion 5 02-08-2014 07:04 AM
4.0ohv lope/misfire at idle.. CEL pepps 4.0L OHV & SOHC V6 Tech 4 06-10-2009 12:50 PM
99 Ranger Rough Idle CEL Codes Xer0Crash General Technical & Electrical 9 04-09-2008 02:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.