rough idle, stalls out on cold crank - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-16-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: Greenville SC
Posts: 3
rough idle, stalls out on cold crank

i have a 1994 ford ranger xlt w/ 183,000 miles. when i start it up i runs fine for about 2 secs. then starts idling rough, and on a few occasions it stalls out (mainly on cold crank) ive sprayed the MAF sensor, changed out the IAC, changed the fuel filter, and the air filter. i am still having the same issue as before. Any ideas on what it could be?
Reply With Quote
  #2  
Old 01-16-2011
blueranger06's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
I'm guessing its not throwing a code? I had the same problem with mine and it was the mafs and I cleaned it but it will still do it sometimes and the check engine light will flash. You said you sprayed your mafs with cleaner and still does it so I'm not really sure.
Reply With Quote
  #3  
Old 01-17-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: Greenville SC
Posts: 3
no its not throwing any codes, the check engine light doesnt come on. i did spray the MAF. i was thinking maybe the fuel pressure regulator maybe?
Reply With Quote
  #4  
Old 01-17-2011
blueranger06's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Quote:
Originally Posted by theboling View Post
no its not throwing any codes, the check engine light doesnt come on. i did spray the MAF. i was thinking maybe the fuel pressure regulator maybe?
Can you get your hands on a fuel pressure tester?
Reply With Quote
  #5  
Old 01-18-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: Greenville SC
Posts: 3
yea i believe i cant rent one from the parts store. though the employees there say it might be my O2 sensor (which none are ford enthusiasts) you think it could be the O2 sensor?
Reply With Quote
  #6  
Old 01-18-2011
blueranger06's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Well I was hoping someone would chime in and help me diagnose it for ya. O2 sensor would give you a code but so should the mafs. Let me do a little more research and see if I can help.
Reply With Quote
  #7  
Old 01-18-2011
blueranger06's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Check your vac lines
Reply With Quote
  #8  
Old 01-18-2011
blueranger06's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2009
Location: Lake Worth, FL
Posts: 246
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 E350 stalls while idling... this truck NEVER stalls. Ever..??? FMD General Ford Discussion 1 10-31-2016 02:53 AM
Rough idle and stalls TimD 4.0L OHV & SOHC V6 Tech 1 09-26-2013 12:26 PM
Rough idle and engine stalls at high rpms. evadfa General Ford Ranger Discussion 1 10-24-2011 07:00 AM
Crank, crank, crank xXcecinestpasXx86 General Technical & Electrical 7 05-08-2009 11:35 AM
rough idle at cold temp it seems..... hartmen SOHC - 2.3L & 2.5L Lima Engines 6 09-30-2008 10:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:06 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.