Ranger-Forums - The Ultimate Ford Ranger Resource

Ranger-Forums - The Ultimate Ford Ranger Resource (https://www.ranger-forums.com/)
-   2.9L & 3.0L V6 Tech (https://www.ranger-forums.com/2-9l-3-0l-v6-tech-32/)
-   -   Sputter/Bucking Under Load (https://www.ranger-forums.com/2-9l-3-0l-v6-tech-32/sputter-bucking-under-load-101483/)

blackedoutv6 02-05-2010 12:32 AM

Sputter/Bucking Under Load
 
Hey all!

I've got a little problem I need some help with ASAP.

My brother has a 2001 3.0 ranger. About 90% of the time if you give it 3/4 to full throttle it starts bucking back and forth real bad until you let off the throttle. Its the worst if you punch it around 50-60mph.

I'm pretty mechanically inclined, but I'm kind of at a loss here.

I've changed the plugs, wires, coil pack, air filter, gas filter, PCV valve. The tune up seemed to help, but definitely didnt fix the problem.

I found this thread, but didn't really get any definite answer..
https://www.ranger-forums.com/forum2...puttering.html

Any help is appreciated guys :smileford:

blackedoutv6 02-06-2010 12:18 AM

bump :sadwavey:

OTRtech 02-06-2010 03:46 AM

Could be low fuel pressure or a flat spot in the TPS (throttle position sensor).

blackedoutv6 02-06-2010 07:41 PM

what could cause the low fuel pressure issue?
injectors maybe?

can you voltage test ranger TPSs?
if so, what should the reading be?

oh btw the truck has about 80k on it..

TheStig88 02-06-2010 08:06 PM

check your sparkplugs

may be time to replace them

blackedoutv6 02-06-2010 08:28 PM

Quote:

Originally Posted by blackedoutv6 (Post 1591776)
I've changed the plugs, wires, coil pack, air filter, gas filter, PCV valve. The tune up seemed to help, but definitely didnt fix the problem.

Quote:

Originally Posted by TheStig88 (Post 1592979)
check your sparkplugs

may be time to replace them

:beerchug:

TheStig88 02-06-2010 08:30 PM

*facepalm

Mazdaman99 02-08-2010 09:30 AM

does it have a CEL....DPFE sensor causes bucking problems


All times are GMT -6. The time now is 06:11 PM.