stalling out! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-19-2011
EMS's Avatar
EMS EMS is offline
Member
Thread Starter
 
Join Date: Jul 2011
Location: Lake City, MI
Posts: 2
stalling out!

hello, I am new to this forum and i have a problem emerging with my Ranger at the moment and i hope some one could possibly shed some light on what might be wrong with it.

the truck is a 94" Ford Ranger 3.0L(182 cubic inch) 2wd auto

there are two problems I am encountering both started at the same time.

when i drive up to a light or stop at( rolling about 10mph will stall also) all my RPMs will slip under 500 and i will begin to stall out this first started curring about a week ago. I thought it might have been that the air filter was choking it so I took it off, but still it stalls to this day. any suggestions on what i should look for on this problem would be helpful

the other problem, other than stalling is a hard shift that comes in to play about 60mph and will set off the check engine light. but when i go under 25mph it will shut the light off again.

please and shank u.
Reply With Quote
  #2  
Old 07-22-2011
Member
 
Join Date: Oct 2010
Location: Nokomis,Fl
Posts: 23
Not sure about the hard shifting thing. But the other sounds like a Vacuum leak. Last week I changed my plugs an wires. The next Morning I started it up to go to work an it was running like crap when I was at a stop or my foot was off the gas. I was thinking that I might of not plugged one of the wires on all the way until I was coming to a stop an it felt like I had none!! That's when I pulled over an saw I knocked the Vacuum hose from the Master Cylinder off. Plugged it back in an no probs since!!
Reply With Quote
  #3  
Old 07-28-2011
EMS's Avatar
EMS EMS is offline
Member
Thread Starter
 
Join Date: Jul 2011
Location: Lake City, MI
Posts: 2
well I'll go out tomorrow and make sure i have all my plugs on tight, I did have a vacuum hose come off but i sealed the hose with a screw my mechanic (Works for a Ford dealership) had said that the hose goes to my cruise control( which never had worked) and would not affect the motor.but to see if that is my problem with my truck i am going to go and hook up that hose again...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Warm start up's stalling out xhosebx1054 4.0L OHV & SOHC V6 Tech 3 05-27-2011 09:50 PM
Stalling at idle? b3kbruiser 2.9L & 3.0L V6 Tech 4 12-24-2006 05:38 PM
Battery Light , Alternator bad, truck stalling, wont hold charge ......... pushdeck General Technical & Electrical 5 11-09-2006 12:17 AM
engine stalling/running rich ranger024x4 4.0L OHV & SOHC V6 Tech 9 02-09-2006 05:35 PM
truck stalling out striker01 2.9L & 3.0L V6 Tech 18 09-05-2005 03:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.