Start problem - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-26-2008
Member
Thread Starter
 
Join Date: Mar 2008
Location: Erie,Pa.
Posts: 6
Start problem

Hey guys, i have a 99 ranger 3.0 4x4 . My truck has done this about 3 times in the last month or so , wondering if anyone has any ideas . Go out in the morning to go to work ,try to start my truck ,and it just turns over but wont start, put the pedal to the floor , starts right up but has no power for 30 seconds or so and then revs right up and runs fine .I can tell right away when its gonna do this , because my truck always starts right up . Was just wondering if i have a sensor or something that might be going bad .Would like to take care of it before it strands me somewhere . Thanks in advance.
Reply With Quote
  #2  
Old 11-26-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
When was the last time the fuel filter was changed?
Reply With Quote
  #3  
Old 11-26-2008
Member
Thread Starter
 
Join Date: Mar 2008
Location: Erie,Pa.
Posts: 6
changed it about 6 months ago
Reply With Quote
  #4  
Old 11-27-2008
htjunkie's Avatar
Member
 
Join Date: Apr 2007
Location: The Lone Star State
Posts: 1,286
Maybe try and seafoam it? maybe get the injectors cleaned?
Reply With Quote
  #5  
Old 11-29-2008
Bryan22's Avatar
Member
 
Join Date: Nov 2008
Location: Lancaster, ca
Posts: 211
if you put your foot on the floor when starting I beleive it turns the injectors 'off' for lack of a better word. does it smell like theres alot of raw fuel when it fires and does this? and for that first 30 seconds are there any other symptoms?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
only start on easy start kyde General Technical & Electrical 2 05-25-2014 06:17 AM
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 08:07 AM
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 10:53 AM
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 05:27 PM
Idle problem on cold start up jdugan4859 2.9L & 3.0L V6 Tech 12 06-01-2005 06:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:10 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.