strange problem - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-07-2010
9ranger8's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2008
Location: Brick, nj
Posts: 163
strange problem

hey guys whats up i have a slight problem with my truck,first off, its a 1998 3.0 v6 5spd not quite sure what is happening, just wondering if maybe it has happened with anyone else. when im driving and i go into neutral my truck revs real high,and if im driving and about to come to a stop when i throw it in neutral it revs and when i come to a complete stop it starts to go back down to normal, thanks for any info you may have!
Reply With Quote
  #2  
Old 09-07-2010
Black1987's Avatar
Member
 
Join Date: Jan 2010
Location: clinton twp, michigan
Posts: 352
im not trying to sound like a dick but is ur foot maybe on the gas pedal a little bit
Reply With Quote
  #3  
Old 09-07-2010
9ranger8's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2008
Location: Brick, nj
Posts: 163
Quote:
Originally Posted by Black1987 View Post
im not trying to sound like a dick but is ur foot maybe on the gas pedal a little bit

LOL no trust me thats what i thought at first, but when i put it in nuetral sometimes just to make sure i take both feet and put them against my seat far away from pedals lol and it still happens, i took it to my uncles shop for an oil change recently and i mentioned the problem, and he cleaned the throttle body out, and it seemed to stop but its back
Reply With Quote
  #4  
Old 09-07-2010
olecountryjohn89's Avatar
Member
 
Join Date: Aug 2010
Location: kentucky
Posts: 86
Maybe a vac leak.
Reply With Quote
  #5  
Old 09-07-2010
Paul Spickard's Avatar
Member
 
Join Date: Jun 2010
Location: Alexander City, Alabama
Posts: 250
Quote:
Originally Posted by olecountryjohn89 View Post
Maybe a vac leak.
Thats what it sounds like to me
Reply With Quote
  #6  
Old 09-08-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
Iac?
Reply With Quote
  #7  
Old 09-08-2010
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
If there are no vacuum leak or throttle cable issues, then you're looking at a possible Throttle Position Sensor or Idle Air Controller.
Reply With Quote
  #8  
Old 09-14-2010
gillette87's Avatar
Member
 
Join Date: Sep 2010
Location: Milton, WA
Posts: 21
had the same deal with mine, it would idle all over the place, and my truck being an automatic... Just replaced the TPS and problem solved
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
strange tranny problem? xbreaka Drivetrain Tech 3 01-27-2008 10:41 PM
Strange CB Problem 0RangerEdge2 General Technical & Electrical 4 12-14-2007 10:46 AM
strange problem cdn2x4ranger 2.9L & 3.0L V6 Tech 1 10-28-2007 09:52 AM
Strange brake problem kimmer415 Drivetrain Tech 3 05-01-2007 12:49 AM
Strange ground noise problem. slodsm Audio & Video Tech 3 11-15-2006 05:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:38 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.