Thermostat or Sending Unit ? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-30-2010
d1zturbe3d's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: California
Posts: 234
Thermostat or Sending Unit ?

Hey guys,

So my truck has a CEL I pulled the code and i got P0128.Now i know the code is basically saying that my truck isn't reaching the operating temperature. So i was thinking of changing the thermostat since i have a feeling it might be stuck open but i have also heard that it can be the sending unit.

Now my question is which would you guys recommend i change first or which is more likely to be causing the problem?
Reply With Quote
  #2  
Old 08-30-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
i would go with the thermostat first. They are fairly cheap and not hard to put in.
Reply With Quote
  #3  
Old 08-30-2010
d1zturbe3d's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: California
Posts: 234
Quote:
Originally Posted by ccosgrove71 View Post
i would go with the thermostat first. They are fairly cheap and not hard to put in.
yeah that was the way i was leaning towards and its what i will do i just wanted to ask in case someone had encountered the same issue.
Reply With Quote
  #4  
Old 08-31-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
that p0128 may have caused your truck to throw that p0316 on your other post.
Reply With Quote
  #5  
Old 08-31-2010
mikerider's Avatar
Member
iTrader: (8)
 
Join Date: Oct 2006
Location: Renton WA
Posts: 2,504
should be the thermostat same code was thrown in my truck, replaced the thermostat and no problems since.
Reply With Quote
  #6  
Old 08-31-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
i would do the thermostat and flush the cooling system
Reply With Quote
  #7  
Old 09-06-2010
SkidPlate's Avatar
Member
 
Join Date: Sep 2010
Location: La Crete , Alberta
Posts: 43
Before you throw a part at it you can always do a little diagnostics to see if it's the sensor or the thermostat. Take the truck for a little ride then turn the heat on high, if you have no or low heat it's the thermostat if you have good heat it's the sensor.
Reply With Quote
  #8  
Old 09-06-2010
d1zturbe3d's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: California
Posts: 234
Well i changed the thermostat yesterday. I picked up one from napa and so far so good. The old thermostat didn't seem to be bad or anything but now with the new thermostat the temperature gauge reads right in the middle. Before it would be about 1/4 up from Cold. It idles smoother than before now and so far no CEL light.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
thermostat sending unit pimpinkn General Ford Ranger Discussion 1 04-05-2010 10:09 AM
thermostat sending unit pimpinkn SOHC - 2.3L & 2.5L Lima Engines 1 04-05-2010 09:46 AM
Temp sending unit Diabolic 2.3L & 2.5L I4 Tech 6 02-21-2008 03:48 PM
is this my oil sending unit? also, how do i take off my fan? Bigdank 4.0L OHV & SOHC V6 Tech 12 01-01-2008 06:03 PM
Oil pressure sending unit......where? KnightRider 2.9L & 3.0L V6 Tech 5 09-16-2005 09:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.