truck running hot, losing transmission fluid - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 09-09-2010
Member
Thread Starter
iTrader: (2)
 
Join Date: Jul 2009
Location: Charleston,WV
Posts: 95
Oh man, I thought I updated this...

Spent about 12 hours fixing the broken bolt/ mucked up threads...had to end up using a helicoil...

But after replacing thet tstat and flushing the cooling system, the truck runs great now...no problems with the tranny, and no overheating...I hope it stays that way...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake Light on and Losing Fluid? tpatten General Ford Ranger Discussion 5 02-07-2012 08:01 PM
Losing tranny fluid, but not on the floor? solo48 Drivetrain Tech 5 08-01-2011 12:26 AM
Help! Truck running hot. MugenCRX04 4.0L OHV & SOHC V6 Tech 6 01-07-2010 06:24 PM
Need some help with truck running hot jtfoxman General Technical & Electrical 17 12-08-2008 08:34 AM
Truck running hot bryanjints 4.0L OHV & SOHC V6 Tech 21 08-10-2007 07:00 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.