Where does this go to??? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-20-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
Where does this go to???



Its coming off the top of the fuel tank so im guessing its a vent tube?? Where does it go though towards the back of the truck?? I followed the line towards the back of the truck and the end of the line is melted probably from my exhaust of course.... but is it supposed to be connected to something or what. Please help me, lol thanks all
Reply With Quote
  #2  
Old 03-20-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
That line goes to your evaprative canister. Its located just infront of your sparetire mount on the crossmember. It needs to be connected to that canister.
Reply With Quote
  #3  
Old 03-20-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
ooooo, could this be a cause of my missfire? do you think???
Reply With Quote
  #4  
Old 03-20-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
Possibly as it leaves the fuel circut open and you probably getting air pocets in the lines. It happened on my 00 thats why I know what this is the second I looked at it
Reply With Quote
  #5  
Old 03-20-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
Its suppose to connect to this right?

Reply With Quote
  #6  
Old 03-20-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
yup thats the one. You should be able to get the line at your local ford dealer. I got lucky as mine was just unplugged. Let me know when you go get it how much it is. I have one of the 00 that I dont need anymore, but mine was a 4.0. PAy shipping and its yours if you need
Reply With Quote
  #7  
Old 03-20-2009
TrePaul86's Avatar
Member
iTrader: (8)
 
Join Date: Apr 2007
Location: Gresham, OR
Posts: 1,369
So that's what you were talking about lol
Reply With Quote
  #8  
Old 03-20-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
I was just gonna go to an auto zone and get me the same size fuel line and make my own!!! zip tie it all up and bam im done lol
Reply With Quote
  #9  
Old 03-20-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
Quote:
Originally Posted by TrePaul86 View Post
So that's what you were talking about lol

yes sir lol haha
Reply With Quote
  #10  
Old 03-20-2009
TrePaul86's Avatar
Member
iTrader: (8)
 
Join Date: Apr 2007
Location: Gresham, OR
Posts: 1,369
That's what I'd do. It's not a specialty part. I didn't realize that's what you're talking about though Chris. I could have told you that too haha
Reply With Quote
  #11  
Old 03-20-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
Well i didnt want to explain it again and when i asked, i saw i had posts about it so i didnt proceed on asking lol
Reply With Quote
  #12  
Old 03-20-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
That should do the trick.
Reply With Quote
  #13  
Old 03-20-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
Thanks for the help all, Ive been doing everything to find out what this intermittent misfire was caused by, hope this fixes the problem :)
Reply With Quote
  #14  
Old 04-01-2009
Member
 
Join Date: May 2005
Location: .
Posts: 87
my truck is misfiring im going to check that right now, let us know if it fixed your problem
Reply With Quote
  #15  
Old 04-01-2009
MudSlanger's Avatar
Member
Thread Starter
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
no it didnt, mine is eiter a coil pack or injector
Reply With Quote
  #16  
Old 05-22-2009
RedRanger91XLT's Avatar
Member
 
Join Date: May 2009
Location: Woodbridge, VA
Posts: 316
I recommend getting the computer checked out. If you have your own code reader you can plug it in and roll. If not, you can go to auto zone and they can pull the codes for free!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 Owners, how does your horn sound? Mnemonic General Technical & Electrical 25 07-03-2005 07:29 PM
Does this look normal or abnormal for a chop? aftermarket New Ideas 7 10-12-2004 03:05 PM
Where does the "alignment cam kit" go? DaytonaBchRanger Suspension Tech 1 10-10-2004 10:34 AM
Does anybody know the wire color for the dome-light offhand? Wowak General Technical & Electrical 9 09-22-2004 09:37 AM
Does anyone have PIAA 525's? RangerXLT Exterior Semi-Tech 0 08-08-2004 01:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:35 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.