1994 4.0 4x4 chugs when warm - Ranger-Forums - The Ultimate Ford Ranger Resource

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

1994 4.0 4x4 chugs when warm

Reply

 
 
 
  #1  
Old 08-08-2007
greygooseranger's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
1994 4.0 4x4 chugs when warm

Hey guys, a coworker of mine was telling me that his ranger wouldn't get over 50 mph when warmed up and was chugging (like in traffic). He took it in and the mechanic changed the fuel regulator, fuel filter, and the o2 sensors. Now he said it gets up to freeway speed fine but still chugs and only when its hot. What is it?

Thanks,
Chris
 
Reply With Quote
  #2  
Old 08-08-2007
wydopnthrtl's Avatar
Member
iTrader: (2)
Join Date: Dec 2005
Location: Ohio
Posts: 2,454
If it's running good when cold then it's getting plenty of fuel. (uses more fuel when cold)

After warm up the mixture leans out and the egr opens more and more.

I'd suspect either ignition or egr.

Rich
 
Reply With Quote
  #3  
Old 08-08-2007
greygooseranger's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
What is the cheapest way to go about diagnosing the problem?
 
Reply With Quote
  #4  
Old 08-08-2007
greygooseranger's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
He said he thinks the EGR was replaced last year, but doesn't know for sure. He also said that the door chimes when the key isn't even in it, and the lower cover of the steering colum is exposed. I don't think thats what you meant by ignition though....
 
Reply With Quote
  #5  
Old 08-08-2007
greygooseranger's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
bump...
 
Reply With Quote
  #6  
Old 08-08-2007
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
could be a dead plug....mine did the same thing and it was a bad plug.......also might be a bad coil pack...it might get hot and expand causing something to not make contact...
 
Reply With Quote
  #7  
Old 08-08-2007
greygooseranger's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
did they have coil packs in 94? I thought it was a distributor?
 
Reply With Quote
  #8  
Old 08-08-2007
brichmond's Avatar
Member
Join Date: Dec 2006
Location: IA
Posts: 116
have him get new plugs an wires i have same truck an same problem.. turned out to b theplugs being bad.. have him clean the maf sensor too that might help...and yes 94 4.0s do have coil pack
 
Reply With Quote
  #9  
Old 08-09-2007
Rockledge's Avatar
Member
Join Date: Nov 2006
Location: Connecticut
Posts: 479
FWIW, the 4.0L never had a distributor.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JohnbII
SOHC - 2.3L & 2.5L Lima Engines
2
06-09-2014 10:44 PM
13weberc
2.9L & 3.0L V6 Tech
1
11-19-2013 05:53 PM
america8371
General Ford Ranger Discussion
19
10-02-2008 07:15 PM
capkid65
SOHC - 2.3L & 2.5L Lima Engines
12
03-27-2006 06:31 PM
mx98ranger
Audio & Video Tech
15
01-12-2006 10:20 PM


Thread Tools
Search this Thread
Quick Reply: 1994 4.0 4x4 chugs when warm


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.