2002 4.0 Ranger rough ldle with heat?? - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-18-2011
MassRanger's Avatar
Member
Thread Starter
 
Join Date: Apr 2010
Location: Worcester, Ma
Posts: 11
2002 4.0 Ranger rough ldle with heat??

OK so my 2002 ranger just started doing this weird thing. When the truck is warmed up and ONLY when the heat is on, the ac compressor kicks on for about a second then turns off. it does this about every 10-15 seconds. When the compressor kicks on the Idle drops real low and almost stalls then the compressor with turn off and the idle goes back to normal?

One other thing i noticed. Typically the ac compressor normally turns on in most cars only if the ac is or and or the defrost. With that said the ac compressor does NOT make the noise when i turn it to the top vents only or if i change it to the floor vents only....this only happens wierdly enought when the combo "vent and feet" vents are on.

Any thoughts...????

Last edited by MassRanger; 02-18-2011 at 08:50 PM.
Reply With Quote
  #2  
Old 02-19-2011
powerranger262's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2009
Location: Hartford, WI
Posts: 1,222
The cycling is normal, but it shouldn't be stalling your truck. Maybe bad bearings or it's starting to go.
Reply With Quote
  #3  
Old 02-20-2011
MassRanger's Avatar
Member
Thread Starter
 
Join Date: Apr 2010
Location: Worcester, Ma
Posts: 11
yea i dont know, i searched the web and got multi responces...some said bad ac compressor or starting to seize....one said Idle air control valve ( IAC ) dirty or going and another who had the same exact issue said it needed a reflash....but i dont feel like gettting raped by the dealer...i guess ill start with the cheapest thing first.

Last edited by MassRanger; 02-20-2011 at 01:35 PM.
Reply With Quote
  #4  
Old 02-20-2011
powerranger262's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2009
Location: Hartford, WI
Posts: 1,222
Yeah, try cleaning your IAC, and while your at it, pull your Throttle Body off and clean all that gunk out of there too.
Reply With Quote
  #5  
Old 02-20-2011
MassRanger's Avatar
Member
Thread Starter
 
Join Date: Apr 2010
Location: Worcester, Ma
Posts: 11
Well i ripped out the throttle body and the idle Air control valve....cleaned both of them up, which were pretty nasty.....and this fixed my idle issue, Nice and Smooooth

Thank You!!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
Heat blower stopped, then started, now stopped heat works nanookc General Technical & Electrical 4 02-17-2015 02:18 PM
2002 Ranger; A/C & Heat Blows Air Thru Defrost Vents Only vsromero General Technical & Electrical 6 05-30-2012 04:36 AM
1997 Mazda b2300 starting rough, running rough! bonecrusher SOHC - 2.3L & 2.5L Lima Engines 3 03-19-2011 05:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.