Air in Cooling System? - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-16-2010
vansnxtweek's Avatar
Member
Thread Starter
 
Join Date: Feb 2005
Location: USA
Posts: 2,666
Air in Cooling System?

I have been having a problem with the heat and defrost system in my truck for awhile. After I run the heat or defrost on warm for awhile I get this persistant noise/knock. Its repetitious and it seems rhythmic when it happens. It just repeatedly goes" boom boom boom" about 3-5 seconds spaced apart until I cut it off. As soon as I cut it off it goes away. I was talking to my grandad and he sugessted it could be air in the system? It def. Seems like its coming from the heatercore/firewall area as far as I can tell. I also seem to have a water leak problem that I have repeatedly looked for but I can't find in the passenger area of the cab but I don't think its related.

Any help is much appreciated.
Reply With Quote
  #2  
Old 12-16-2010
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Sounds like your heater core is leaking.
Reply With Quote
  #3  
Old 12-17-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Unplug the clutch on the A/C compressor and see if that makes the noise disappear.
As for the leak , is it water or antifreeze ?
Reply With Quote
  #4  
Old 12-17-2010
vansnxtweek's Avatar
Member
Thread Starter
 
Join Date: Feb 2005
Location: USA
Posts: 2,666
I def. Don't think the heater core is leaking because its not antifreeze that I'm finding. I'll try that with the a/c clutch.
Reply With Quote
  #5  
Old 12-18-2010
vansnxtweek's Avatar
Member
Thread Starter
 
Join Date: Feb 2005
Location: USA
Posts: 2,666
Anyone else ever experienced this?
Reply With Quote
  #6  
Old 12-18-2010
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Take the radiator cap off with the truck cold. Let it idle 15 20 minutes with it off and the heat on high. Top it off if needed.

This will ensure there is no air in the system, if the noise goes away you had air. If it comes back you have a coolant leak.
Reply With Quote
  #7  
Old 12-19-2010
Timberwolf's Avatar
Member
 
Join Date: Oct 2010
Location: East coast Canada
Posts: 706
that problem was the first question I asked when i joined the forum. I never got a proper answer. By the looks of it though, Blhde might have answered my problem. Gonna try that in the morning. Im quite sick of people asking why my rig, which has 60,000km's makes a knocking noise in park, with the heat on. Sweet baby jesus! Finally!
Reply With Quote
  #8  
Old 12-19-2010
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
also could be the blend door actuator
Reply With Quote
  #9  
Old 12-19-2010
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
wait wait wait...if it is the thumping from under the hood, hold one of the radiator hoses and see if it jumps when the thump happens...if so there is a fix TSB for it...PM me for info and prices
Reply With Quote
  #10  
Old 12-19-2010
vansnxtweek's Avatar
Member
Thread Starter
 
Join Date: Feb 2005
Location: USA
Posts: 2,666
Quote:
Originally Posted by Toreador4x4 View Post
also could be the blend door actuator
I just learned today that I think this may be the problem or the blower motor itself! I did the cap off idle and it didn't get rid of it. Does the blower motor itself control the blend door?
Reply With Quote
  #11  
Old 12-19-2010
Timberwolf's Avatar
Member
 
Join Date: Oct 2010
Location: East coast Canada
Posts: 706
Is this a ranger thing?!
Reply With Quote
  #12  
Old 12-19-2010
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
the blend door controls hot and cold not the blower motor....first feel the hoses as i mentioned...because you dont want to dig into the dash for no reason
Reply With Quote
  #13  
Old 12-20-2010
vansnxtweek's Avatar
Member
Thread Starter
 
Join Date: Feb 2005
Location: USA
Posts: 2,666
Quote:
Originally Posted by Toreador4x4 View Post
the blend door controls hot and cold not the blower motor....first feel the hoses as i mentioned...because you dont want to dig into the dash for no reason

Okay will do..i'll check the hoses tomorrow. Thanks for the help!!
Reply With Quote
  #14  
Old 12-20-2010
Member
 
Join Date: Dec 2010
Location: Nanaimo,B.C. CANADA
Posts: 51
Now I know my truck is old...Controls cold and hot.Hot is when you put the heater on ,cold is opening(ROLL DOWN ) the window. I am going to need a RANGER DICTIONARY. I thought you guys were yankin when I saw this Blend dour control. Oh I have to come back and keep reading....This place is like gettin addicted to Days of our lives at lunch hour as a teen.(Only one semester) got over it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Cooling System Problem 0RangerEdge2 2.9L & 3.0L V6 Tech 3 02-06-2009 05:53 AM
new cooling system(engine) now leaking mps01r6 2.3L & 2.5L I4 Tech 1 12-16-2008 12:15 PM
Vac. In Cooling System pacepace87 2.9L & 3.0L V6 Tech 0 06-29-2008 02:05 PM
Cooling System Help Please? BeeDee SOHC - 2.3L & 2.5L Lima Engines 2 04-28-2008 12:06 PM
Cooling System Problem Need help JTG 2.9L & 3.0L V6 Tech 3 08-24-2007 08:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:24 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.