Another problem :( - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-28-2008
Alex98's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
Another problem :(

Upon starting if the engine isnt a lil warm or has been sitting a while, it wont always have a smooth start and sometimes it will fumble around a little bit and then start. The only things i can think of are low fuel pressure or get a new battery. Anyone have any suggestions?
Reply With Quote
  #2  
Old 08-28-2008
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
Fuel Filter sounds like it needs changing Your injectors are pumping what little they can get out of your old filter's deteriorated/blocked filtering process.. causing it to "fumble" on starting..
Reply With Quote
  #3  
Old 08-29-2008
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
I had a pontiac that did the same thing once. Once it was running it was good.

Turned out to be the fuel filter.

Rich
Reply With Quote
  #4  
Old 08-29-2008
Alex98's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
replaced it tho
Reply With Quote
  #5  
Old 08-29-2008
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Been a wet year this year . Throw a can of drygas in the tank.
Reply With Quote
  #6  
Old 08-30-2008
Alex98's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
alright ill give that a try
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another day, another bunch of pics Seb_L Snapshots 8 05-26-2010 02:52 PM
This can't be good... another problem GrafixGuy General Technical & Electrical 21 09-13-2007 10:08 PM
Another O2 sensor Problem! smallello General Technical & Electrical 7 09-09-2007 07:54 PM
Another 4x4 problem. Bourgeois88 Drivetrain Tech 8 08-23-2006 10:25 AM
One problem after another Sychodemeanor Suspension Tech 5 05-17-2006 06:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:41 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.