ant-theft device - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-02-2014
Member
Thread Starter
 
Join Date: Jan 2014
Location: Fort McMurray
Posts: 2
ant-theft device

At the end of 10 hour drive. Check engine light comes on. Tach, speedo, temp guage not working. Briefly check engine light goes out, guages work and then problem returns. Pull over to check out and when try to start truck, anti-theft light blinking and no start. Nothing from starter or solenoid and no fuel pump priming. Any suggestions?
Reply With Quote
  #2  
Old 01-02-2014
Member
 
Join Date: Oct 2013
Location: Maine
Posts: 45
Can you get a code scan done? If any codes, they may tell ya what is happening. Not sure if PATS is the issue, as the truck was running when this happened. Also when the truck is not running my "theft" light blinks, kinda a visual deterrent to the thieves. LOL.
Hope this helps.

Eric
Reply With Quote
  #3  
Old 01-02-2014
Member
Thread Starter
 
Join Date: Jan 2014
Location: Fort McMurray
Posts: 2
Thanks Eric. Towed truck to closest dealership. A couple of codes not sure what. PCM lost communication. Mechanic unplugged connectors to PCM and IC cleaned them and truck good to go. Hope he is right. Another 500 miles to home. Still not sure if PCM or IC are on their way out, connections were dirty or taking power off modules caused them to reset. Mechanic wasn't sure what the root cause was but showed me what he did and gave me the spray can of contact cleaner and wished me luck
.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
where did you mount your sirius radio ant. silverfox Audio & Video Tech 22 10-17-2010 02:24 AM
CB ANT Mount question.... doc General Ford Ranger Discussion 6 02-26-2006 05:05 PM
Little Ant Problem HighRollerII General Ford Ranger Discussion 16 09-14-2005 04:41 PM
What's your favorite electronic device in your truck? TippnOver General Technical & Electrical 39 08-29-2005 06:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.