BAD misfire - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-02-2009
OVERtheEDGE's Avatar
Member
Thread Starter
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
BAD misfire

ok well some of you know about the little misfire i used to have w/ my truck, well i pulled the egr and it quit. so drove it awhile and had no problems at all. well went to crank it up one morning and IT RAN LIKE CRAP, its now just not drivable b/c it misfires and jerks so bad. got a CEL saying misfire cylinder #4 i made sure its getting spark and the plugs are fine. i just dont know whats wrong. its also been loosing antifreeze, seems to be coming from the driver side head maybe. but its not getting in the cylinder or it would blow white smoke and it doesnt. so what the heck is wrong w/ that 4.0? im out of ideas. replaced the egr today too, and ran block sealer through it too.
Reply With Quote
  #2  
Old 03-02-2009
OVERtheEDGE's Avatar
Member
Thread Starter
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
Icon4

BUMP!!!!!!!!!!!!!!!!!!!!!!!!!!
Reply With Quote
  #3  
Old 03-02-2009
OVERtheEDGE's Avatar
Member
Thread Starter
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
HELP>>>> need to have fixed asap, it my only vehicle! info would be great
Reply With Quote
  #4  
Old 03-02-2009
Lord Of War's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2006
Location: Thornton, Colorado
Posts: 4,599
Take is to a Ford Dealership or some where similar and have them look at it.
Reply With Quote
  #5  
Old 03-02-2009
OVERtheEDGE's Avatar
Member
Thread Starter
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
[QUOTE=Lord Of War;1234493]Take is to a Ford Dealership or some where similar and have them look at it.[/QUO]

**** that. i'll scrap it before i take it to ford. i can fix if i could figure out the problem
Reply With Quote
  #6  
Old 03-02-2009
Jp7's Avatar
Jp7 Jp7 is offline
Member
iTrader: (9)
 
Join Date: Sep 2007
Location: My LED lab or on the dyno
Posts: 2,970
compression testamundo time.

if you are leaking antifreeze you might have a busted head gasket or a cracked head.

I just fixed a turbo 350z that needed a similar operation

Take the heads off and look at the gasket. If it is super clean in one area you have a leak for sure. I use a stethescope and boroscope sometimes.
Reply With Quote
  #7  
Old 03-02-2009
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
From 5 days ago.
Quote:
Originally Posted by rwenzing View Post
4.0 OHV's are famous for misfires on #4. It might possibly be a head or head gasket problem but there is a much more common cause. Often, a leak in the gasket between the intake manifold and the head will allow coolant to be sucked into #4 intake runner and cause the misfire and coolant loss.
Reply With Quote
  #8  
Old 03-02-2009
OVERtheEDGE's Avatar
Member
Thread Starter
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
Quote:
Originally Posted by rwenzing View Post
From 5 days ago.
ok i thought you meant it would get sucked into the cylinder? its not or there would be white smoke, theres none. spefically what am i looking for? can the head gasket cause it to do this? it dont run like its only 1 cylinder misfiring but thats all that the CEL shows. i figure block sealer would have done something but guess not.
Reply With Quote
  #9  
Old 03-02-2009
OVERtheEDGE's Avatar
Member
Thread Starter
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
by the way, compression it great.
Reply With Quote
  #10  
Old 03-02-2009
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
whats great... post numbers and do all the cylinders..

have you pulled the plugs what do they look like post some pics up...

if there is coolant loss 4.0L ohv are known for head gaskets blowing..

also just another spot to check my Coil pack took a **** on my 4.0L ohv and was causing a random misfire to #4
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'98 3.0L Misfire, bad cylinder? fletcher969 2.9L & 3.0L V6 Tech 0 11-02-2013 05:55 PM
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 07:59 AM
will a bad IAC cause bad mpg? MonsterGuy General Technical & Electrical 11 08-06-2007 04:29 PM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 12:50 PM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 08:21 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.