gas gauge issue - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-05-2011
Off-roadranger04's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Location: Newark, Delaware
Posts: 1,751
Icon5 gas gauge issue

My gas gauge has been giving me false readings. The tank will be full and im driving and it goes totally empty. Or i'll have a 1/2 tank and it will be full. What could be going bad and what would need to be fixed.

Thanks
Reply With Quote
  #2  
Old 05-05-2011
legoms013's Avatar
Member
 
Join Date: Mar 2011
Location: Loomis CA
Posts: 280
Either the float is half attached and sporadic, or more likely the pickup for the electrical contact patch that takes the electrical signal from the arm that is attached to the float, is going bad.

If it stays the same, or gets worse buy a new sending unit. they are about $100 and includes a new fuel pump as well.

Or possibly the wiring is ragged somewhere between the tank and the dash panel.
Reply With Quote
  #3  
Old 05-09-2011
Off-roadranger04's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Nov 2008
Location: Newark, Delaware
Posts: 1,751
She ended up throwing a check engine light... cant remember the code but it was fuel sensor A. So i'll probably pick up a new sending unit.
Reply With Quote
  #4  
Old 05-14-2011
Member
 
Join Date: May 2011
Location: Tampa Fl.
Posts: 23
Quote:
Originally Posted by Off-roadranger04 View Post
My gas gauge has been giving me false readings. The tank will be full and im driving and it goes totally empty. Or i'll have a 1/2 tank and it will be full. What could be going bad and what would need to be fixed.

Thanks


replace the fuel tank sending unit...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gas Gauge and temp gauge help!! T12icky0 General Technical & Electrical 1 02-14-2013 03:41 PM
trans issue, and i mean issue rangerdanger01 Drivetrain Tech 2 01-09-2011 01:13 PM
Is it a timing issue or a fuel issue? Drewbis SOHC - 2.3L & 2.5L Lima Engines 7 08-13-2010 07:16 AM
Gas cap/gauge issue. Plz Help. RLong31 4.0L OHV & SOHC V6 Tech 11 03-09-2010 10:31 AM
Oil Pressure Gauge/Sensor issue? travis8798 General Technical & Electrical 7 08-26-2006 01:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.