High Idle solution - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

High Idle solution

Reply

 
 
 
  #26  
Old 11-21-2017
Member
Join Date: Nov 2017
Location: Gower missouri
Posts: 1
I had the same problem so I took the iac valve off and the float was stuck so I put wd40 in it and let it soak for a little bit and sprayed it out with brake clean and slapped it back on and it runs just fine
 
Reply With Quote
  #27  
Old 11-21-2017
Member
Join Date: Jul 2016
Location: BC Canada
Posts: 1,556
The float was stuck ???
 
Reply With Quote
  #28  
Old 07-24-2018
Member
Join Date: Feb 2015
Location: monkey valley, pa
Posts: 14
had this with my 2004 4.0 auto, idled at 2k. went to the dealer twice, no codes, no explaination for the high idle either. i had them change the aic, it helped a little. my tps went bad after that, so i changed it with no affect.

i then decided to remove the throttle body, aic and mass air and gave it all a good cleaning. re hooked up the battery and all was well for 1 start. then back to 2000rpm idle. so i guessed it was one of the 3 things i cleaned. the mass air being easiest to get to i cleaned it again. truck started and idled perfectly, but only once. then it was back to 2k

i got a new mass air, disconnected the battery and installed it. put it all together and all is well, now a month later still fine. im suprised that the truck never threw a code, even at the ford garage

not saying this is everyone elses problem, but it fixed mine.
 
Reply With Quote
  #29  
Old 07-24-2018
Member
Join Date: Jul 2016
Location: BC Canada
Posts: 1,556
Sounds like disconnecting the battery and allowing the ECM to relearn it's idle is what really needed doing.
Not that any of those things didn't need attention.
 
Reply With Quote
  #30  
Old 1 Week Ago
Diesel_Brad's Avatar
Member
Join Date: Nov 2011
Location: PA
Posts: 224
Have the same issue. My one 04 5 speed 4.0 I have been battling it for 5+ years. it comes and goes but when it comes, I can drive the truck without even touching the throttle pedal. IAC. MASS, throttle cable, etc all changed and NOTHING. I changed the ECM and it was good for 6 months? Then it stated doing it again intermittently.(once every 30 days or so)

Well fast forward to another 04 5 speed 4.0 I just bought. Put it on the road monday and well tues day and 100 miles latter I have a 3000RPM idle. Worse than my other truck.

Suggestions? I just dumped some seafoam in the vacuum hose and letting it sit for 30 min but I'm sure that is not the problem
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
thom2003
2.9L & 3.0L V6 Tech
2
04-25-2018 05:32 PM
4door
2.9L & 3.0L V6 Tech
7
12-16-2010 12:49 PM
htvfd460stx
General Technical & Electrical
7
06-26-2007 07:58 AM
RedRanger02
Drivetrain Tech
8
03-09-2006 04:15 PM
RanJerEDGE
General Ford Ranger Discussion
10
07-09-2004 01:00 PM


Thread Tools
Search this Thread
Quick Reply: High Idle solution


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.