How would i Fix this? - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-23-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
How would i Fix this?

Ok, so my truck has a vaccum leak, and its idaling pretty rough.. Could this particular vaccum leak Also affect the transmission? It is staying in gear alot longer than usual..
Attached Thumbnails
How would i Fix this?-ck130.jpg  
Reply With Quote
  #2  
Old 11-23-2009
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Its leaking form that piece you have circled ? That is your IAC (idle air control) It could also cause transmission problems and you can buy a new one at your local parts store for around 60 i believe.
Reply With Quote
  #3  
Old 11-23-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
um, its just that black cap that is missing.... Is there a way to just cap it off?
Reply With Quote
  #4  
Old 11-23-2009
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Well i just checked on my spare iac.. That black cap will pull off. Personally i would just got yank one off at a junkyard...
Reply With Quote
  #5  
Old 11-23-2009
Alex98's Avatar
Member
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
yea me to just do that there not really worth paying for lol.
Reply With Quote
  #6  
Old 11-23-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
yeah, except there arnt any rangers at the junk yard here... Hmmmm
Reply With Quote
  #7  
Old 11-23-2009
wildbill's Avatar
Member
 
Join Date: Oct 2009
Location: Crestwood
Posts: 308
I would think you could duct tape it up and see if that helps anything.
Reply With Quote
  #8  
Old 11-23-2009
wellcom2knoxvile's Avatar
Member
iTrader: (2)
 
Join Date: Oct 2007
Location: Corvallis, OR/Seattle, WA
Posts: 1,390
easy fix = duct tape and zip ties!!!!
Reply With Quote
  #9  
Old 11-23-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
thanks guys. you think i should reset the PCM, or will i not need to?
Reply With Quote
  #10  
Old 11-24-2009
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
Edited since it was before you were tearing into it...

If that's it, I believe I have the old IAC I pulled off somewhere. If I can find it, you pay shipping and i'll send it to you.

Last edited by Toms994x4; 11-24-2009 at 05:35 PM.
Reply With Quote
  #11  
Old 11-27-2009
04DSGMike's Avatar
Member
 
Join Date: Nov 2009
Location: Riverside, CA
Posts: 485
just get a new one...cheap part to replace so why not go new
Reply With Quote
  #12  
Old 11-28-2009
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
Quote:
Originally Posted by 04DSGMike View Post
just get a new one...cheap part to replace so why not go new
Considering the fact that he's in Germany, and the "new one" costs $60, it's not exactly cheap.
Reply With Quote
  #13  
Old 11-28-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
thanks tom.. Im gunna take it back to the shop next week and have him find out why the hell its running so rough.. At idle it sounds like it has a big cam.. And at full throttle it just sounds rough.. HOpefully its just a vacuum leak and he can find it.. although they seem to be quite sneaky..
Reply With Quote
  #14  
Old 11-28-2009
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
Did you check that little black hose I circled in the picture?
Reply With Quote
  #15  
Old 11-28-2009
lumpy4000's Avatar
Member
 
Join Date: Aug 2009
Location: Orillia, Ontario
Posts: 379
use something to plug it and some heat shrink tubing to hold it in place. duct tape will melt from the engine heat and make a big mess...
Reply With Quote
  #16  
Old 11-29-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
Tom- Yes i did.

Lumpy- thanks, i have masking tape on it right now, seems to be holding up to the heat.. But still something isnt right.. It hasnt really made a difference plugging the whole.. SHould i Reset my PCM?
Reply With Quote
  #17  
Old 11-29-2009
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
The hole is suppose to be vented. The cap is like a dust protector.

A typical vacuum leak will have poor idle and be fine mid to high rpms. if you have issues at all rpms, I would look at ignition and fuel issues.

No CEL?
Reply With Quote
  #18  
Old 11-29-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
no CEL which makes it even harder to figure it out
Reply With Quote
  #19  
Old 11-29-2009
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Check your spark plugs. See if you have any that not looking good.

Clean your MAF, and reset the computer.
Reply With Quote
  #20  
Old 11-30-2009
God,Country,FORD's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
spark plugs are fine.. Maf was just cleaned.. It hAs to be the IAC.. I think I am going to see about getting a new one.. Its idiling REALLY rough, and getting ****tier gas maleage than before i did the heads
Reply With Quote
  #21  
Old 11-30-2009
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Does it run rough at all rpms?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
how much would it cost ti fix this cmaskel Fabrication & Tool Tech 15 10-16-2010 06:17 PM
Anyway to fix smashed in rocker panels? PwrRngr Exterior Semi-Tech 22 05-21-2009 08:47 AM
so then would you say this would be better? DeMar17 Audio & Video Tech 1 05-04-2009 05:54 PM
How can I fix my sagging headliner? RhodeRanger Interior Semi-Tech 7 12-02-2008 11:28 AM
would a 99 explore cluster fix a 96 ranger cbranger96 General Ford Ranger Discussion 1 10-14-2006 12:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.