no codes anymore... still won't idle!!! I need help asap - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-02-2010
bigredneck61088's Avatar
Member
Thread Starter
 
Join Date: Aug 2008
Location: Hubbard OH
Posts: 13
no codes anymore... still won't idle!!! I need help asap

The story is... 98 4.0 ohv, throwing p0171 and p0174 both banks, both lean, changed MAF, still threw the codes, cleared em. Now the codes haven't been back but the truck has gotten progressively worse running and will not idle, lopes real bad. Fuel Pressure and filter in fine condition.

Then I replaced the upper intake (rubber ones) and the paper one below the fuel rail (lower??) as per on the sites. No change after that!! Haven't had the codes come back yet. I am stumped and i need to get back to work, any help/input appreciated. I have scoured for vaccum leaks and cannot find any. PCV or IAC maybe?? I just need another direction to go i am stumped.

I also replace the plugs and wires and no change either

Last edited by bigredneck61088; 11-02-2010 at 11:11 PM.
Reply With Quote
  #2  
Old 11-22-2010
jayray's Avatar
Member
 
Join Date: Mar 2010
Location: Milton, Ontario, Canada
Posts: 16
Stretched, or jumped timing chain causing the cam to be out slightly?
Reply With Quote
  #3  
Old 11-22-2010
Turbo Roadster's Avatar
Member
 
Join Date: Jul 2007
Location: Lancaster, CA
Posts: 277
Have you used a vacuum gage and checked your readings at idle? If so what were you getting?
Reply With Quote
  #4  
Old 11-23-2010
Alex98's Avatar
Member
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
did you replace the upper intake gasket?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Codes and Codes fraser19 General Ford Ranger Discussion 0 06-14-2013 03:14 PM
idle still screwed up I need help! daranger101 2.9L & 3.0L V6 Tech 25 03-11-2012 12:28 PM
CODES CODES- IDLE issue supraboatguy General Technical & Electrical 1 11-08-2011 02:17 AM
Need help ASAP: Exhaust system won't pass inspection in Mass annguyen1981 General Ford Ranger Discussion 35 05-20-2010 03:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:37 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.