Please help - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-13-2009
Member
Thread Starter
 
Join Date: May 2009
Location: scranton, pa
Posts: 28
Icon8 Please help

my check engine light is on i put it on the computer and it told me that i had an egr problem bought a new egr valve and installed it. light went out for about an hour and it came back on put it back on computer and it showed that i still had an egr problem. had new egr checked and it is working fine. ralso replaced line to valve thought it my have been leaking no not the problem. is there another egr sensor on my truck and if so where can it be located. i have a 2001 ranger with a 4.0 sohc motor any advice will be greatly appreciated. I AM NEW TO THE SITE PLEASE HELP ANYONE
Reply With Quote
  #2  
Old 05-13-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Check the lines to the egr and the "block" think that the line goes to. Its called the DFPT or something like that

Last edited by whippersnapper02; 05-13-2009 at 01:00 AM.
Reply With Quote
  #3  
Old 05-13-2009
Member
Thread Starter
 
Join Date: May 2009
Location: scranton, pa
Posts: 28
thanks but i already replaced the vacum line . the local wanna be mechanics at autozone said that there might be an electronic selenoid control on the motor. is that the control that the egr valve vavum goes to? and if so could that be a part of the problem. the engine runs fine except for a decrease in fuel mileage
Reply With Quote
  #4  
Old 05-13-2009
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
As egr flow deteriates so does mileage. I don't know much about the sensor.. but I'd check into that as well.

Also, I'm pretty sure it not a problem but.. make sure the passage from where the EGR mounts to the intake air passage is not plugged. On my 4.0L it's very short and I don't think it would ever get plugged. But.. I've seen this happen on MANY other engines.

Rich
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
PLEASE PLEASE PLEASE.... annguyen1981 General Ford Ranger Discussion 13 12-05-2013 03:35 PM
please tell me where my PCV is, Please (did search) uplandhunter General Technical & Electrical 16 02-07-2011 09:34 AM
E-Brake help. Please help me out. Need to get done asap. rybread5520 General Technical & Electrical 2 01-02-2009 10:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.