problem with my SOHC - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
problem with my SOHC

well i dont trust hardly anyone but myself to do anything with the vehicle im driving, and the oil that was in my truck just looked crappy so i decided id change it. well i sat in front of the oil rack at autozone trying to decide what to get for it, and i finally decided on the Castrol semi synthetic stuff(10w-30). well i start it up this morning and theres this annoying clicking coming from my engine, i just ignore it but its only there when im on the accelerator and it clicks faster the higher i get in the rpm's. should i have chosen a different oil?
Reply With Quote
  #2  
Old 05-03-2008
greygooseranger's Avatar
Member
 
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
What type of oil filter? Have you checked the oil level? How many miles are on the truck?
Reply With Quote
  #3  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
70000 miles, k&n oil filter, oil level is right on the money, it just clicks
Reply With Quote
  #4  
Old 05-03-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Are you sure your not hearing the injectors? Everyone complains about a tick and it is usually the injectors.
Reply With Quote
  #5  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
well im new to the 4.0, only had it since monday, still figuring it out if you know what mean, now i could tell ya a bunch on my 3.0!
Reply With Quote
  #6  
Old 05-03-2008
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
Sounds like a dirty injector. Try running some Lucas injector cleaner through a couple tanks of gas.
Reply With Quote
  #7  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
oh yeah i forgot, i pulled the #5 plug just to see what condition theyre in and i put it back in last night too, could that have anything to do with it?
Reply With Quote
  #8  
Old 05-03-2008
greygooseranger's Avatar
Member
 
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
No, I don't think so....

Try running fuel system cleaner (I like seafoam myself) and change your fuel filter. Then report back....
Reply With Quote
  #9  
Old 05-03-2008
SparkYZ's Avatar
Member
 
Join Date: Nov 2007
Location: Granada Hills, CA
Posts: 679
Does it sound like clicking a pen? If so, it's the injectors. It's a 4.0 SOHC thing.
Reply With Quote
  #10  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
yah it does sound like a pen, ill seafoam the crap out of it and then change the plugs that way i dont ruin the new ones, thanks for the help guys!
Reply With Quote
  #11  
Old 05-03-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Does it sound like this? That is injector noise.
Reply With Quote
  #12  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
comes more from the drivers side, ill go take a vid and see if it picks up the noise, i mean i can hear it very clearly in the cab when im driving
Reply With Quote
  #13  
Old 05-03-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Exhaust manifold leak?
Reply With Quote
  #14  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
ill have to check that out too
Reply With Quote
  #15  
Old 05-03-2008
My05edge's Avatar
Member
Thread Starter
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
cool thing is that if anything is wrong with it i get to take it back to the idiots at the chevy dealership and get it fixed for free! 30 day 3000 mile warranty! once again thanks for the help guys!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2006 Ranger 4.0 SOHC Lean problem - likely vacuum leak freddie 4.0L OHV & SOHC V6 Tech 8 12-03-2013 07:19 PM
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 06:58 AM
4.0 SOHC starting problem Yellow_edge_4x4 4.0L OHV & SOHC V6 Tech 20 03-30-2009 11:39 AM
Bamachip on a 4.0 SOHC (1/4mile times included) Scallion02EDGE General Ford Ranger Discussion 1 11-11-2004 10:13 PM
Anyone looking for rocker arms for their SOHC... Johawk 4.0L OHV & SOHC V6 Tech 2 09-14-2004 09:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:35 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.