Random Misfire... - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-11-2008
Alex98's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
Random Misfire...

I have a 98 ford ranger with the 4.0L OHV V6 with 140,000k on the truck, and there is a random misfire on one of the cylinders when you put a substantial amount of stress on the engine. Almost all of the engine sensors have been replaced, the spark plugs are fine, spark-plug wires are not worn or frayed, the MAF has been cleaned, and I have replaced the fuel filter as well as had an engine compression test done and the valves are all running within 1lb. of each other. What do you think the cause of this might be?
Reply With Quote
  #2  
Old 07-11-2008
67cobain94's Avatar
Member
 
Join Date: Jul 2005
Location: Vero Beach, Florida
Posts: 708
Plugs and wires. Replace them. Just because they're not frayed doesn't mean they aren't bad. And your eyes can't see a crack that would be big enough to cause engine problems. Don't ever assume the obvious is good when it comes to working on cars. Also if your cylinders are within 1 pound of each other you might want to check your gauge. You're allowed about 25% difference from one cylinder to the other because there's usually always about a 20 pound spread over the cylinders from high to low. If you replace plugs and wires and it's still doing it, I'd look for something like a weak valve spring which won't show up in a compression test unless the valve isn't closing, or worn out valve seats etc. Hope this helps.
Reply With Quote
  #3  
Old 07-16-2008
Alex98's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
i replaced the plugs with bausch +4's figuring if that didnt solve it then nothing would and it worked quite well i now have all of my performance mods on
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Misfire, Random ping, and black smoke TheChairman SOHC - 2.3L & 2.5L Lima Engines 1 06-24-2012 06:54 PM
Some Random Pic's ........In Random Places DallyBoy09 Snapshots 11 06-28-2009 10:38 PM
Misfire 4,5,6 help. JDRead 2.9L & 3.0L V6 Tech 10 09-24-2008 02:10 AM
Engine misfire???? phatspeed7x 4.0L OHV & SOHC V6 Tech 4 07-02-2006 09:08 AM
Misfire TBarCYa 4.0L OHV & SOHC V6 Tech 5 02-23-2005 11:14 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:45 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.