Truck shuts off in reverse, rough idle in Drive. - Ranger-Forums - The Ultimate Ford Ranger Resource

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Truck shuts off in reverse, rough idle in Drive.

Reply

 
 
 
  #1  
Old 12-03-2010
Riddla's Avatar
Member
Thread Starter
Join Date: Jan 2010
Location: Texas
Posts: 140
Truck shuts off in reverse, rough idle in Drive.

Okay the truck is shutting off in reverse, it only used to do it when you locked the steering wheel to one side. Then it started to do it even when going straight in reverse. Now it rough idles when you put it in drive. Put it in neutral and it works like a charm.

No check engine lights or nothing????

4.0 auto. What can the problem be? I am taking it to a mechanic in the morning but just want to get an idea if anyone has one....
 
Reply With Quote
  #2  
Old 12-03-2010
Toreador4x4's Avatar
Member
iTrader: (6)
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
unplug the throttle position sensor and see if it stops...could be a torque converter or a pressure concern
 
Reply With Quote
  #3  
Old 12-04-2010
Riddla's Avatar
Member
Thread Starter
Join Date: Jan 2010
Location: Texas
Posts: 140
I tried it out again. At start up there are no issues at all. After driving for a bit (15 mins) and putting it in reverse, it will bog/rough idle and die pretty quick unless i give it alot of throttle. Put it in Drive and the RPMs will go below 500 and will spike to 1000rpm back and forth a few times before dying (Again,,,unless i give it enough throttle to take off. Normal driving with full power when i take off). I put it back in neutral and the idle issue goes away. Idles at about 800-1000 rpm.. Could it be the transmission? Smooth shifting on all gears
 
Reply With Quote
  #4  
Old 12-04-2010
pacodiablo's Avatar
Member
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
Maybe the idle air control valve (IAC)? Probably not the trans and an IAC is way cheaper.
 
Reply With Quote
  #5  
Old 12-04-2010
seed60's Avatar
RF Veteran
iTrader: (15)
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
I had this problem. I changed spark plugs, cleaned iac, and maf sensor and it went away. Not sure which one fixed it.
 
Reply With Quote
  #6  
Old 12-06-2010
Ranger093's Avatar
Member
iTrader: (1)
Join Date: Jul 2009
Location: Blaine, Minnesota
Posts: 289
Probably IAC had same issue.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jason530
General Technical & Electrical
0
05-19-2013 03:51 AM
fords77
Drivetrain Tech
3
01-12-2012 12:09 PM
chad2584
General Technical & Electrical
6
06-29-2011 02:57 PM
muddmn08
2.9L & 3.0L V6 Tech
2
12-12-2010 05:46 PM
Fordranger1998
SOHC - 2.3L & 2.5L Lima Engines
6
10-02-2007 11:12 PM


Thread Tools
Search this Thread
Quick Reply: Truck shuts off in reverse, rough idle in Drive.


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.