truck wouldnt start earlier - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-16-2008
tylerdavenport's Avatar
Member
Thread Starter
 
Join Date: Dec 2007
Location: Beaverton, Oregon
Posts: 54
truck wouldnt start earlier

So I went to deposit my paycheck a few hours ago and come back out to my truck, and it wouldnt start. Not turning over, nothing. I thought well I'll be damned, I get my check and I have to fix my truck. So I popped the hood and look in my radiator overflow tank because I know it had been low, but I know it isnt a direct cause with my truck not starting. Walked to the gas station and got some anti-freeze/coolant to fill it up with. After that, nothing still. then a dude with an exploder pulls up and helps me out for a while and gets his battery to see if mine is shot. So he loosens my terminals and says try it, and it fires right up like nothings wrong. How did loosening my battery cables let my truck start? We were both very confused. What a great day haha oh yeah and I get to work all weekend while everyone is out playing in the nice warm weather.....
Reply With Quote
  #2  
Old 05-16-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Are your terminals corroded?
Reply With Quote
  #3  
Old 05-16-2008
tylerdavenport's Avatar
Member
Thread Starter
 
Join Date: Dec 2007
Location: Beaverton, Oregon
Posts: 54
hell yeah they are. lol I forgot to mention that part. I need new ones put on ASAP.
Reply With Quote
  #4  
Old 05-16-2008
Seahawk's Avatar
Member
 
Join Date: Mar 2008
Location: Sheboygan County, WI
Posts: 376
yeah im 100% sure it was the terminals if they were corroded.
Reply With Quote
  #5  
Old 05-16-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Thats what the problem is. When the guy loosened them, he must have knocked off some of the corrosion and power was able to get through. Terminals corrode when battery acid gets on them.
Reply With Quote
  #6  
Old 05-16-2008
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
Yes, and the cable itself will corrode way down inside the insulation too, so look for that when you replace the terminals.
Reply With Quote
  #7  
Old 05-16-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
I just bought an Optima so my corrosion issue is gone.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
rolled over but wouldnt fire. ford danger 2.3L & 2.5L I4 Tech 2 07-23-2008 06:36 AM
Truck Wouldnt start, then did... jtslmn720 2.9L & 3.0L V6 Tech 12 08-25-2007 03:00 PM
Truck Wouldnt Start 20 Minutes Ago? Roach2004 General Technical & Electrical 11 03-28-2007 10:39 AM
Truck wouldnt roll today SanityAside 2.9L & 3.0L V6 Tech 8 09-04-2006 11:12 PM
Why wouldnt this fit 04edge Audio & Video Tech 18 04-23-2006 01:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.