airbag light came on after installing new head unit? - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-13-2010
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
Icon4 airbag light came on after installing new head unit?

so im in the process of puttin subs in my 07 f150. we put in the head unit last nite and the airbag light is now on. i googled it and all i could find was that your supposed to disconnect the battery before you change stereos. and that to fix it just drive around and it will eventually go away if thats what is causing it. got any ideas guys?
Reply With Quote
  #2  
Old 04-13-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Easy one! You forgot to plug back in the passenger airbag light in the top of the radio bezel lol. If you plug it back in with the truck on you have to turn it off and restart it and it will be gone.
Reply With Quote
  #3  
Old 04-13-2010
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
thats what it was. lol. the light didnt go off though. its a code 18 i guess. flashes once, pauses, then flashes 8 more times
Reply With Quote
  #4  
Old 04-13-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Try disconnecting the battery, turn on the headlights for 30 seconds and reconnect the battery.
Reply With Quote
  #5  
Old 04-14-2010
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
nope, didnt work. i took off all the positive connections. turned the key and turned the light switch to on for 30sec to a min. then turned off and hooked everything back up
Reply With Quote
  #6  
Old 04-14-2010
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
Quote:
Originally Posted by 04blackedge View Post
Easy one! You forgot to plug back in the passenger airbag light in the top of the radio bezel lol. If you plug it back in with the truck on you have to turn it off and restart it and it will be gone.
what do you mean in the part in red?
Reply With Quote
  #7  
Old 04-14-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
When you plug the light harness back in the bezel you have to do it with the truck off for the light to reset. If you do it with the truck running the light will stay on until you restart your truck.

Is the light still on?
Reply With Quote
  #8  
Old 04-14-2010
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
yea. the truck was off and everything. just the battery wasnt unplugged. my friend might not have put it in right so idk whats up. never did it till we put the stereo in
Reply With Quote
  #9  
Old 04-14-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Yeah I would check and make sure its in right. You don't have to undo the battery or anything while your doing it.
Reply With Quote
  #10  
Old 04-14-2010
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
ok. ill try it next time i get a chance. prolly friday
Reply With Quote
  #11  
Old 04-14-2010
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
Quote:
Originally Posted by kymudder08 View Post
its a code 18 i guess. flashes once, pauses, then flashes 8 more times
2007 F150 - Lamp Fault Code 18 is for a problem with the Passenger Airbag Disable indicator light. Take a look and I'll bet that it is no longer working.

First - make sure that the everything got plugged back in correctly after the audio work. Second - I'm not familiar with the indicator in the F150 but the Ranger PAD bulb is very sensitive to rough handling. The Ranger bulb is not available separately from Ford but a suitable replacement can sourced from an electronics store and soldered in. Maybe the F150 is similar.
Reply With Quote
  #12  
Old 04-15-2010
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
its got a long oval lamp in the radio bezel
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Problem with stock head unit after new speakers! paganwars Audio & Video Tech 3 04-18-2011 01:27 AM
Problem with stock head unit after new speakers! paganwars General Technical & Electrical 0 03-19-2011 07:18 PM
Battery Light Came On After Offroading redranger04g General Technical & Electrical 15 12-09-2007 01:20 PM
Need Help!!!!! Getting A New Head Unit! fletch12518 Audio & Video Tech 18 11-23-2005 11:08 PM
Looking At Getting A New Head Unit... Trevelyn1015 Audio & Video Tech 18 07-02-2005 01:41 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:07 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.