head unit works and amp and sub but no sound from speakers?? - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
head unit works and amp and sub but no sound from speakers??

Yeah i think i fried something in the head unit lastnight. Everything workx except i get no sound out of my door speakers.........I mean display and all features work fine on the head unit, amp and sub still work, just no sound coming from the door speakers. I coming to 2 conclusions. Either i fried the unit eneternally or cooked all the stock wiring ing in the truck.......how bout u, what ya think?
Reply With Quote
  #2  
Old 01-19-2006
AuthPineApple's Avatar
Member
 
Join Date: Jan 2006
Location: Santa Monica, CA
Posts: 420
WAS it just all of a sudden that the door speakers died? Were you cranking it or anything? or just out of the blue bam, dead?
Reply With Quote
  #3  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
wasnt jaming. turned my truck on and poof........
Reply With Quote
  #4  
Old 01-19-2006
AuthPineApple's Avatar
Member
 
Join Date: Jan 2006
Location: Santa Monica, CA
Posts: 420
It maybe be the wiring but Im goin to just state the obvious. First things first. Check the Balance and Fading on the head unit itself, you never know, maybe someone messed with those settings. Secondly if that fails, take out the head unit and make sure everything is connected behind it. If thats still good and speakers are a no go, get speakers from a friend or just some ones laying around and remove one of the door speakers and see if that makes them work, if not, something is definately up. Than you might have to worry that the wiring WITHIN the truck wiring may be bad or the head unit is toasted with that, good luck.
Reply With Quote
  #5  
Old 01-19-2006
Member
 
Join Date: Nov 2005
Location: Aberdeen and Salisbury MD
Posts: 1,840
i was there when the head unit pooped out. fletch turned tuck on and only bass came out of subs. we checked all the settings (balance faders and all that) still only bass. also there was a funny smell to, like something burning
Reply With Quote
  #6  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
im doing all checks tonight. we will see i guess. hopefully jus the head unit and not the wires.
Reply With Quote
  #7  
Old 01-19-2006
mcerwing's Avatar
Member
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
you may have grounded one of the speakers to a door. when that happened to me, i found out it was the passenger speaker that was grounding itself out with the screw that was holding it in place because the speaker was kinda wired wierd
Reply With Quote
  #8  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
so did your head unit work after that?
Reply With Quote
  #9  
Old 01-19-2006
mcerwing's Avatar
Member
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
yeah, it had nothing to do with the head unit... i would just turn on my stereo, and wtf? there was no sound. so i turned it up, and BOOM, the stupid *** bass hit and scared the **** out of me. i took off the door panels and looked at the speakers, and when i started taking it off, i noticed that it sparked which meant it was grounding itself to the door. the speaker was crap anyways, so i just took it out. after that, everything worked fine
Reply With Quote
  #10  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Yeah cus everything still works fine. jus no head unit. jus wondering where the burning smell came from
Reply With Quote
  #11  
Old 01-19-2006
mcerwing's Avatar
Member
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
hmm... burning? that's wierd. hopefully you don't have to replace all the speaker wires, cause that can be a *****
Reply With Quote
  #12  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
yeah....i hope i jus burned up the unit atleast........ believe it or not
Reply With Quote
  #13  
Old 01-19-2006
AuthPineApple's Avatar
Member
 
Join Date: Jan 2006
Location: Santa Monica, CA
Posts: 420
Heh, but than if the speaker wires are messed up, you can have a reason to amp the speakers since you would have to run new wiring anyways, heh. Since you said there was a smell, was it the electrical fire smell? It is a strong smell but do check the wiring and see if any positive/negative wires are touching cause is so than thats the problem. ITs pretty much like said about about the grounding. I got a harness that was premade with electrical tape and popped about 20 fuses so than I took off the tape and the ground + hot were touching and bam, fixed that, no problems since.
Reply With Quote
  #14  
Old 01-19-2006
mcerwing's Avatar
Member
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
Quote:
Originally Posted by AuthPineApple
Heh, but than if the speaker wires are messed up, you can have a reason to amp the speakers since you would have to run new wiring anyways, heh. Since you said there was a smell, was it the electrical fire smell? It is a strong smell but do check the wiring and see if any positive/negative wires are touching cause is so than thats the problem. ITs pretty much like said about about the grounding. I got a harness that was premade with electrical tape and popped about 20 fuses so than I took off the tape and the ground + hot were touching and bam, fixed that, no problems since.
i'm with him. if you have to replace the wiring, amp the speakers. i want to do that someday........
Reply With Quote
  #15  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
the smell wasnt strong at all. very light and bearley nocticable. I have a four chanel amp right now. got 2 channels for each sub. "bridged" and the other side i have 2 channels open.
Reply With Quote
  #16  
Old 01-19-2006
mcerwing's Avatar
Member
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
nice, if i had that my truck would rattle apart. i have a 400 watt kicker with a 12 inch compVR. it hits hard as hell. i couldn't imagine having two in my truck
Reply With Quote
  #17  
Old 01-19-2006
AuthPineApple's Avatar
Member
 
Join Date: Jan 2006
Location: Santa Monica, CA
Posts: 420
Since the smell was faint... could be wiring, but damn, maybe a small fire within the head unit. I know when I was messing with my old motherboard and it burned it make this smell that wasn't disgusting smelling, but like... I dunno, just weird. Didn't smell appealing.
Reply With Quote
  #18  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Quote:
Originally Posted by AuthPineApple
burned it make this smell that wasn't disgusting smelling, but like... I dunno, just weird. Didn't smell appealing.

thats excatly it! thats what i was like! my speakers mad a real quite cracking sound, nothing loud, then there was a smell.......then nothing
Reply With Quote
  #19  
Old 01-19-2006
AuthPineApple's Avatar
Member
 
Join Date: Jan 2006
Location: Santa Monica, CA
Posts: 420
Than yeah, its an electrical fire, either from wires touching or the head unit and since you said that the smell radiated from the head unit, check close to the head unit if not the head unit itself casue im pretty sure checkin the speakers to be the problem might be a waste since the smell came from head unit. But yeah, try some things, stop reply and get workin!! j/k
Reply With Quote
  #20  
Old 01-19-2006
Strider0O0's Avatar
Member
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
EDIT: missed the part about the smell coming from the headunit area, and thought it was just a smell in general that you noticed.. so, i dunno if my advice would help any.. anyway, ill leave it up, for the hell of it.


have you checked the speakers yet? look at the connections on the back of the speakers, and see f you see any burn marks. i had a friend do something similar the other week to his truck while installing a set of front speakers. he connected them just fine, but a few hairs of copper were sticking out of his connectors... they were connecting with one another, and left a few burn marks on the speaker basket, as well as made the speaker sound like it had really bad static, then, like you, nothing.. his speaker did blow though, so, i dunno if it would be anything like that for you. if you havent arleady, check the speakers.
Reply With Quote
  #21  
Old 01-19-2006
AuthPineApple's Avatar
Member
 
Join Date: Jan 2006
Location: Santa Monica, CA
Posts: 420
Could happen, good point. Just try everythin thats suggested, should find something.
Reply With Quote
  #22  
Old 01-19-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
ok i found nothing wrong. hooked speakers up to amp and everything works????? wtf!?
Reply With Quote
  #23  
Old 01-19-2006
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
did you check the wires from the HU to the speakers? might have gotten cut or torn....
Reply With Quote
  #24  
Old 01-19-2006
AuthPineApple's Avatar
Member
 
Join Date: Jan 2006
Location: Santa Monica, CA
Posts: 420
Huh? What you mean? You turned it back on and everything works or what?
Reply With Quote
  #25  
Old 01-19-2006
mcerwing's Avatar
Member
 
Join Date: May 2005
Location: hesperia, ca
Posts: 171
that's good, but you should still check everything, because you don't want it shorting out in the future.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Speakers, amps, and head unit questions PAShooter Audio & Video Tech 7 09-22-2010 04:28 PM
WTB: Head Unit and speakers. MN malydeen Interior, Exterior, Electrical, & Misc. 0 06-30-2009 01:41 AM
Recommend me a head unit and some speakers! SuperKid Audio & Video Tech 23 01-21-2007 12:21 PM
speakers speakers speakers doug435 Audio & Video Tech 5 01-30-2006 01:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:44 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.