Just put in my equalizer need help - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-26-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Just put in my equalizer need help

ok, i need some help. when i put my new eq in I just matched up the color wires to the colors off of my harness for my head unit. Now i ran radio shack rca cables from the head unit to the eq. now when i turn the truck on and off the subs make like a big "thud" noise. very annoying noise! Is it because i have ****ty rca cabes? is it the way i ran the power supply? im guessing morely the rca's

Edit: since i am running my subs through my eq now, my rca's for the back of the head unit now just hangs there. Now, i don't have the metal tips covered up anymore. could it be because they are touching? would that even matter?


if it is rca's would these work? http://www.radioshack.com/product/in...entPage=search

Last edited by fletch12518; 05-26-2006 at 07:01 AM.
Reply With Quote
  #2  
Old 05-26-2006
winks's Avatar
Member
iTrader: (5)
 
Join Date: May 2005
Location: Jackson, New Jersey
Posts: 4,872
I've never had the problem with my EQ, but It may just be what happens when the EQ turns on and off. I don't think it has to do with the RCA jacks because I've never had a problem with the radio shack ones.
Reply With Quote
  #3  
Old 05-26-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
but its a loud thud even when the eq is off!?..................I mean it will scar ya if your not ready for it. even with the eq off, sub boost control off, still does it? idk me confused.....?
Reply With Quote
  #4  
Old 05-26-2006
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
RCA's wont do it, you can have the ****tiest cables and it still wont do it, im not sure about EQ's though....sometimes if i hold my mic for my CB in the right spot everytime key the mic it makes a thud, and my voice goes through the subs....kinda weird..

Rocky
Reply With Quote
  #5  
Old 05-26-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
yeah i gotta get this **** to stop! its very loud! ugh everytime i start the truck up.............? so rca's are a no........
Reply With Quote
  #6  
Old 05-26-2006
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
MAybe it has to do with the wiring, does it come with a wiring diagram or anything? Sounds to me like the power is back feeding when the ignition is turned on and coming out the sub, it cant be good for.....

rocky
Reply With Quote
  #7  
Old 05-26-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
well like i said above. I just tapped in to the wiring from the head unit harness. black to black,red to red, orange to orange.


Edit: I did not run it's own power supply line to the battery, and did not run to its own ground.
Reply With Quote
  #8  
Old 05-26-2006
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Unhook the power and ground....run a power cable from the battery to the EQ (not through the firewall, just through the window to see if it works) ....ground the EQ to something good, and see if it still does it....if it does then just run a power wire, or tap off your hot wire for your amp since you have subs..

Rocky
Reply With Quote
  #9  
Old 05-26-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
yeah thats what i was thinking. i'l give that a shot than
Reply With Quote
  #10  
Old 05-26-2006
winks's Avatar
Member
iTrader: (5)
 
Join Date: May 2005
Location: Jackson, New Jersey
Posts: 4,872
I'm thinking the same thing, give that a try. Its probably just somethin with the EQ.
Reply With Quote
  #11  
Old 05-26-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
I'll try it when i get home. if thts not it me and my uncle are going to hack into it
Reply With Quote
  #12  
Old 05-26-2006
1 loud truck's Avatar
Member
 
Join Date: Nov 2005
Location: MASS
Posts: 157
mine did the same thing make sure you have a good ground and what i did to get rid off it was also ground the eq chassis ...
Reply With Quote
  #13  
Old 05-30-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
ya i got it. i grounded the ground for the eq to the chassie and so far so good!
Reply With Quote
  #14  
Old 05-30-2006
winks's Avatar
Member
iTrader: (5)
 
Join Date: May 2005
Location: Jackson, New Jersey
Posts: 4,872
Glad to hear you solved the problem. How do you like having the EQ in there?
Reply With Quote
  #15  
Old 05-31-2006
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
man its good but my cousin is going to hook me up with a Kenwood eq later on. kinda messed up the cut around the eq, but its not bad! I have pics and stuff of this weekend and my eq but my internet was not working at my moms house!!!!! grrrrr i hate that! ill get em up asap!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: Equalizer, TV & Bandpass Box - Lehigh Acres, FL draggindakota Interior, Exterior, Electrical, & Misc. 0 04-23-2010 10:31 AM
New headunit and equalizer is in winks Audio & Video Tech 25 02-13-2006 05:50 PM
pretty good equalizer for truck???? fletch12518 Audio & Video Tech 19 02-12-2006 12:17 AM
Just put LED taillights in SONICEDGE03 General Technical & Electrical 15 06-13-2005 06:42 PM
Just put some new seats in the Ranger! SONICEDGE03 Interior Semi-Tech 24 02-14-2005 10:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:02 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.