new sub (2 12" xplods) and a 1000W xplod amp - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-14-2012
newfrank's Avatar
Rock Doctor
Thread Starter
iTrader: (1)
 
Join Date: Jul 2010
Location: Oakville, Ontario
Posts: 184
new sub (2 12" xplods) and a 1000W xplod amp

Hey guys,

I just got a custom box with two 12" sony xplods and a 1000 Watt sony xplod amp for free. I was just wondering how these subs are? I see a lot of hate twoards em, but since they were free, ill give em a shot.

Also, will my 8GA wire be good enough to power that amp? I think the truck it came out of had 4GA but that may have been overkill.

The subs and amp came out of a 2006 chevy avalanche. An old guy drove it and had them installed, so they weren't beat too hard. My dad bought it as a crappy company truck and didn't want em so I got them.

Also, I'm on my blackberry and I tried to upload a pic, not sure if it worked, so bear with me haha.

Frank
Attached Thumbnails
new sub (2 12" xplods) and a 1000W xplod amp-img-20120514-00002.jpg  
Reply With Quote
  #2  
Old 05-14-2012
Lord Of War's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2006
Location: Thornton, Colorado
Posts: 4,599
Its funny you posted this because I was just given an Xplod in a 10in. I had always heard bad things about them but when I hooked it up to my amp (1000w / 4 channel) it sounded really good. Its in my F-150 and I couldnt be happier with it.
Reply With Quote
  #3  
Old 05-14-2012
2004xlmiller's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2010
Location: Sac, CA
Posts: 1,601
i ran one of these sony's a 12in 1000W xplode. i loved it, i couldnt understand why people disliked them so much. i ran it with a 1000W amp and it hit pretty hard for an entry level sub. i still have it, just not in my truck.
Reply With Quote
  #4  
Old 05-23-2012
Member
 
Join Date: Jul 2010
Location: Delaware, Ohio
Posts: 82
If it was free, then you should have no remorse in using them! They are pretty low quality though, and I've seen a lot of them blow up. That's usually because they are in the price range of teenagers who don't know what they're doing though. Properly setup they should last you quite a while.

I actually used to have an xplod amp, and I ran 4ga to it. There is really no harm in running larger cable. Besides, if you ever want to upgrade you don't want to have to redo it all.
Reply With Quote
  #5  
Old 05-23-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
Quote:
Originally Posted by newfrank View Post
Hey guys,

I just got a custom box with two 12" sony xplods and a 1000 Watt sony xplod amp for free. I was just wondering how these subs are? I see a lot of hate twoards em, but since they were free, ill give em a shot.

Also, will my 8GA wire be good enough to power that amp? I think the truck it came out of had 4GA but that may have been overkill.

The subs and amp came out of a 2006 chevy avalanche. An old guy drove it and had them installed, so they weren't beat too hard. My dad bought it as a crappy company truck and didn't want em so I got them.

Also, I'm on my blackberry and I tried to upload a pic, not sure if it worked, so bear with me haha.

Frank
They arent bad, but back to back with something like my clarion, there no comparing.

1 guage atleast for 1000 watts. i have 1 guage and im running less then 1000 watts. its much better to be safe then sorry. but you'll be happy with them if youve never had a sub. BUT, just wait till you invest in some nice ones. my one 12" clarion aluminum is 3x louder and more powerfull then my old 12" sony xplod with the exact same amp.
Reply With Quote
  #6  
Old 05-23-2012
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Free always sounds better lol
Reply With Quote
  #7  
Old 05-23-2012
buggman's Avatar
Member
iTrader: (38)
 
Join Date: Apr 2007
Location: Dougal County
Posts: 1,648
Free stuff is the best stuff!

Looks like that box is waaaay too small for them though. You should be able to get the specs for the subs online to make an appropriately sized box for your truck though.

I've never heard them, but I've always liked Sony car audio stuff. Their subs probably aren't going to win any awards for SPL or sound quality, but for the average Joe they're probably just fine.
Reply With Quote
  #8  
Old 05-27-2012
mikey7o2's Avatar
Member
 
Join Date: Mar 2012
Location: las vegas nv
Posts: 60
Yeah you can never go wrong with free!!! As far as running a 8awg kit for the amp I wouldn't recommend it. Its not that you cant use 8awg but the smaller wire will have the amp pulling more power from your system and can cause your lights to dim and other issues. If you can I would use a 4awg kit (Memphis audio makes a quality kit thats not to hard on the wallet) that way its not pulling so hard on the electrical system. Some people (like myself) would run 0-1awg wire kit just to be on the safe side but you really don't have to. I'm not a big fan of Sony car audio I never really liked how it sounds and I have a friend who is running 2 Sony 1200w 12's with a Sony 1000w amp and my 1 Alpine Type X with 600w not only sounds better but hits harder as well.
Reply With Quote
  #9  
Old 05-27-2012
Member
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
The subs will last longer than the amp, never had an issue with the subs, the amps are crap though.

Free works - I'd run the 4ga also, once and done...
Reply With Quote
  #10  
Old 05-27-2012
SteelDirigible's Avatar
Member
iTrader: (4)
 
Join Date: May 2010
Location: Lexington, KY
Posts: 3,666
4 ga is what yous should go with, its what I have on my 1200. that amp terminal isn't made for 1 gauge anway, I'm sure you be cutting it down to size.
Reply With Quote
  #11  
Old 06-25-2012
newfrank's Avatar
Rock Doctor
Thread Starter
iTrader: (1)
 
Join Date: Jul 2010
Location: Oakville, Ontario
Posts: 184
Alright, thanks fellas. I still haven't put them in my truck, I do like my setup right now haha so I may just sit on these for a bit and when I feel like it throw some 4ga in there and git 'er done.

Quote:
Originally Posted by 06RangerXLT View Post
They arent bad, but back to back with something like my clarion, there no comparing.

1 guage atleast for 1000 watts. i have 1 guage and im running less then 1000 watts. its much better to be safe then sorry. but you'll be happy with them if youve never had a sub. BUT, just wait till you invest in some nice ones. my one 12" clarion aluminum is 3x louder and more powerfull then my old 12" sony xplod with the exact same amp.
I have a 10" kicker with an alpine amp with 8ga. I'll go down to 4ga since I'll never do anything huge. Right now it hits pretty damn hard and I'm happy with it. I was just curious 'cause free is awesome.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New "member" & "supporter" images... buggman Ranger-Forums Office 1 06-02-2012 12:20 AM
For Sale: Custom Sub Box, amp and 12" Sub, Ex Cab only - Melbourne, FL pushdeck Interior, Exterior, Electrical, & Misc. 1 05-02-2010 11:39 AM
sony Xplod amp blackrainja08 Audio & Video Tech 2 10-09-2006 05:49 PM
holy **** im gonna freak, is my new xs-l101p5 xplod blown!??? hardcoresmylife Audio & Video Tech 39 07-02-2005 12:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.