sound issues - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-23-2009
knsdrms3's Avatar
Member
Thread Starter
 
Join Date: Aug 2008
Location: the dorf md
Posts: 24
sound issues

kinda confused right now i have an alpine 9884 and im using it to power 4 infinity 982.9s. whenever i turn it up above 15 volume, which is about halfway, the sound starts to get really garbly and distorted and i lose bass, but this only lasts for about 30 seconds at most and then it sounds normal for a few seconds and keeps going back and forth between garbly and clear.

this recently just started happening as i used to be able to hit 20 volume before it started to barely distort. and i only did this very seldomly. im pretty sure its not the speakers as they can handle up to 100w rms so....could this be the internal amp going bad?
Reply With Quote
  #2  
Old 05-24-2009
Turbo Roadster's Avatar
Member
 
Join Date: Jul 2007
Location: Lancaster, CA
Posts: 277
Have you checked your power connections, is the amp getting hot?
Frist thing I would do is connection test with the amp on, wiggle your wires at the amp and at the battery check your grounds also.
Reply With Quote
  #3  
Old 05-24-2009
mlw20lu's Avatar
Member
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
possibly. by your description it doesnt sounds like your running an external amp. If your using 100rms speakers then you shouldnt be running them of the MOSFET Apling head unit that only supplys 25x4 MAX watts. there isnt enuff power going to the speakers. so on a big power pull its not getting the power the need.
Reply With Quote
  #4  
Old 05-25-2009
knsdrms3's Avatar
Member
Thread Starter
 
Join Date: Aug 2008
Location: the dorf md
Posts: 24
yea i meant the amp in the headunit itself. i have the speakers running straight from the headunit. so if i went and picked up an amp, then i probably wouldnt have that problem anymore?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gauge issues/heating issues/high oil pressure Fw87 General Ford Ranger Discussion 2 04-26-2015 12:08 AM
speaker/sound issues TCP_Ranger Audio & Video Tech 3 06-09-2009 09:52 PM
Got Dual Exhaust? (now w/ sound clip) Wowak General Ford Ranger Discussion 16 09-06-2004 10:36 AM
The Sound of Stang AllBlackStang New Ideas 3 08-06-2004 09:47 PM
Strange sound from dashboard of my dad's 98 Ranger.. help? Wowak General Technical & Electrical 0 08-02-2004 10:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:35 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.