Stock radio doesnt get power - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-13-2004
Zero's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Poteau, Oklahoma
Posts: 435
Well I'm left clueless now. After my new radio was stolen I was finally able today to get a new bezel and put my stock player back in. For some reason my radio gets no power now. I checked the plug and all the wires and they seem to be fine. I'm really clueless, does the CD-6 have a lockout or something? I have no clue why it wont work. Thanks for any replies.
Reply With Quote
  #2  
Old 10-13-2004
 
Join Date: Jun 2004
Posts: 0
Stock radio doesnt get power

Did you have to modify the stock harness to get the aftermarket to work?

Is the fuse good? (might have blow when they took your stuff?)
Reply With Quote
  #3  
Old 10-13-2004
Zero's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Poteau, Oklahoma
Posts: 435
Nope, didnt modify it a bit. Used a converter so I didnt have to touch a wire on the stock harness. I checked the side panel (Left side of cab) fuse and it was fine. thanks for the reply.
Reply With Quote
  #4  
Old 10-13-2004
 
Join Date: Jun 2004
Posts: 0
hmm, other than what I said above, I haven't touched a CD6 so I don't know what else to try.
Reply With Quote
  #5  
Old 10-13-2004
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
Use an Ome meter on the White wire? I just put one in last week and didnt have any porblems
Reply With Quote
  #6  
Old 10-13-2004
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
i dont remember if its white or red or ether of them
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Stock Radio with power but no sound dancemiker Audio & Video Tech 0 04-03-2014 12:07 PM
WTB: Stock radio and stock rims roushdealer Suspension, Tires, & Wheels 6 06-13-2009 04:25 PM
New axle pivot drop bracket doesnt line up freebird900 Suspension Tech 5 11-13-2006 09:10 AM
tranny doesnt want to shift 04edge Drivetrain Tech 6 04-07-2005 06:36 AM
Active Users link doesnt work for me Zero Ranger-Forums Office 2 01-27-2005 12:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:13 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.