'09 slight miss - Ranger-Forums - The Ultimate Ford Ranger Resource


DOHC - 2.3L Duratec / Mazda L Engines Discussions and Topics specific to the Duratec 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-09-2012
grunt98444's Avatar
Level III Supporter
Thread Starter
 
Join Date: Feb 2010
Location: Bremerton, WA
Posts: 126
'09 slight miss

after high idle and before it's full warmed up it sounds like it's sputtering and an occational miss
any ideas on what's going on?

Thanks,
Richard
Reply With Quote
  #2  
Old 03-09-2012
Member
 
Join Date: Feb 2012
Location: Windsor, WI
Posts: 93
Quote:
Originally Posted by grunt98444 View Post
after high idle and before it's full warmed up it sounds like it's sputtering and an occational miss
any ideas on what's going on?

Thanks,
Richard
Have you checked for any pending or set codes, if any could be helpful. How many miles, engine, etc.
Reply With Quote
  #3  
Old 03-09-2012
grunt98444's Avatar
Level III Supporter
Thread Starter
 
Join Date: Feb 2010
Location: Bremerton, WA
Posts: 126
Sorry,
14,000 miles on a 2.3 Duratec, 5sp auto
No Codes, runs fine when warmed up.
Reply With Quote
  #4  
Old 03-09-2012
Member
 
Join Date: Feb 2012
Location: Windsor, WI
Posts: 93
Quote:
Originally Posted by grunt98444 View Post
Sorry,
14,000 miles on a 2.3 Duratec, 5sp auto
No Codes, runs fine when warmed up.


When was the last time a tune up was done??? Have you ever cleaned the Mass Airflow Sensor with mass airflow sensor cleaner? Does it make a difference if it is wet out???

You could check your plug wires whenn it dark to see if any spark is being lost.
Reply With Quote
  #5  
Old 03-09-2012
Jrevans2002's Avatar
Member
 
Join Date: Apr 2008
Location: Chicago, Ill
Posts: 560
Maybe moisture under the plug wires at the coil pack.
Reply With Quote
  #6  
Old 03-09-2012
grunt98444's Avatar
Level III Supporter
Thread Starter
 
Join Date: Feb 2010
Location: Bremerton, WA
Posts: 126
thanks for the responce
the truck only has 14,000 miles on it, so it shouldn't need a tune up, will check the Mass Airflow sensor
doesn't seem to make a difference if it rains or not, will also check out the plug wires
Reply With Quote
  #7  
Old 03-09-2012
Member
 
Join Date: Feb 2012
Location: Windsor, WI
Posts: 93
Quote:
Originally Posted by grunt98444 View Post
thanks for the responce
the truck only has 14,000 miles on it, so it shouldn't need a tune up, will check the Mass Airflow sensor
doesn't seem to make a difference if it rains or not, will also check out the plug wires
Sorry I misread it as 140K instead of 14K, not use to a vehickle with so little miles on it.
Reply With Quote
  #8  
Old 03-09-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
you should be still under warranty. bring it back (assuming you bought it from dealership)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
rough idle/ slight miss bsan84 4.0L OHV & SOHC V6 Tech 2 02-04-2015 04:08 PM
Just got this truck about a month ago and just noticed a slight miss today. Only happ EagleWSO General Technical & Electrical 0 07-19-2013 08:57 PM
Slight knocking. PlasticHero Drivetrain Tech 4 10-01-2008 08:17 AM
slight slippage?? hozII Drivetrain Tech 5 09-15-2008 08:09 PM
Slight Electrical Problem w. Truck. EdGe_wannabe General Technical & Electrical 9 12-21-2006 11:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.