Please Help, High idle - Ranger-Forums - The Ultimate Ford Ranger Resource


DOHC - 2.3L Duratec / Mazda L Engines Discussions and Topics specific to the Duratec 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-03-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: martinez, ga
Posts: 2
Please Help, High idle

okay, I have a 1999 regular cab 5 speed manual 2.5, and for some reason when im driving, ill goto push my clutch in and my motor wil start to rev up really high and doesnt stop until a few seconds after im at a complete stop, anyone have this problem or know what may be causing this, i would deeply appreciate it,

thanks for the help
Reply With Quote
  #2  
Old 08-04-2010
t5cents's Avatar
Member
iTrader: (6)
 
Join Date: Nov 2008
Location: Eureka, CA
Posts: 1,521
IAC...search
Reply With Quote
  #3  
Old 08-04-2010
nofatchx's Avatar
Member
 
Join Date: Aug 2010
Location: DUM
Posts: 30
its the throttle position sensor!!!!!!!!!! two phillips screws take it off dont get it from autozone id go dealer or elsewhere i had this problem also i did clean out the idle air motor with carb cleaner too ive known 5 people with this problem
Reply With Quote
  #4  
Old 08-04-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: martinez, ga
Posts: 2
THANKS YOU GUYSSS!!! ive been tryin to figure this out for agesssss, hopefully this works
Reply With Quote
  #5  
Old 11-17-2010
Member
 
Join Date: Nov 2010
Location: dora, al
Posts: 5
did replacing the TPS work?
Reply With Quote
  #6  
Old 11-19-2010
Marchy's Avatar
Member
 
Join Date: Dec 2009
Location: Redmond, WA
Posts: 287
Cleaning the IAC and replacing the TPS got this issue under control on my truck, my idle still hangs every once in a while (mostly when its very hot outside) so i think i'll eventually have to replace the IAC but it doesn't hurt the running of the motor. same year same motor same transmission.

edit: Also when you clean the IAC, replace the gasket that goes on there (1$ from napa) because when i first cleaned my IAC the issue did no go away and only once i replaced the gasket did it go away.
Reply With Quote
  #7  
Old 11-19-2010
Member
 
Join Date: Nov 2010
Location: dora, al
Posts: 5
thank you. i have a new iac but not TPS,
Reply With Quote
  #8  
Old 09-08-2012
Member
 
Join Date: Sep 2012
Location: WOODRUFF
Posts: 2
I'm having this problem as well. I changed the IAC last year and it went a way for a good while. The problem is back. One variation from the poster. Mine does not idle back down once I get to a stop, it continues to run very high until I start going again and 1st gear forces it into a slower mode. It seems to want to go faster as well. Do I need another IAC or could it be something else?
Reply With Quote
  #9  
Old 10-03-2012
97ranger xlt's Avatar
Member
 
Join Date: Feb 2007
Location: Mass.
Posts: 459
a bad pcv valve will cause a high idle and not throw a code.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
High Idle / Low idle 2003 Ranger 3.0 thom2003 2.9L & 3.0L V6 Tech 1 03-27-2012 01:12 AM
High idle and dying 2.9 V6 engine.. Help pacmanj4 General Ford Ranger Discussion 34 01-04-2011 04:55 PM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM
2000 ranger way high idle. please help!!!! RickStar SOHC - 2.3L & 2.5L Lima Engines 5 09-29-2009 07:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.