2000 ranger 4.0 4x4 help. - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-12-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: newark
Posts: 4
2000 ranger 4.0 4x4 help.

i have a 2000 ranger 4.0 4x4. first thing it was fine then no matter where i put shifter i have a low drive gear. it goes to p. i can put shifter in any other position and it is in low drive no matter if shifter is in r/n/d/2/or 1. and 2ed i drive the truck it dont get hot but when the truck off it will blow antifrezz out of the over flow. it dont over heat but yet everytime u shut it off it blows out the overflow. plz help
Reply With Quote
  #2  
Old 03-12-2010
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
wait a min you have 2 problems you worded that all odd...

first your hear indicator says its always park? your prindle is broke inside take apart the dash and find whats problem on the cable.

now you also have an antifreeze problem?
Reply With Quote
  #3  
Old 03-12-2010
--weezl--'s Avatar
Member
iTrader: (1)
 
Join Date: Sep 2009
Location: Calgary AB, Canada
Posts: 3,139
no i think what he said is when he takes it out of park, it goes automaticly into 1st gear, he has no reverse, netrual, drive 3rd? 2nd? only park and first... but i could be wrong

and an overheating issue... i say the over heating is thermostat
Reply With Quote
  #4  
Old 03-12-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: newark
Posts: 4
no. the the truck is in park when the shifter is in p. as soon as i move the stifter no matter if i put it in r-n-d-2-1 it is in a low drive gear. it goes stright from p to a low gear nothing else. and yes i also have water antifreeze issue. it runs good dont get hot. but it blows out the overflow bottle. i was thinking linkage on tranny and i have no clue on antifreeze. hope thats more clear. sorry im about to go crazy
Reply With Quote
  #5  
Old 03-12-2010
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
radior cap may be bad on the coolent issue and on the trans i would take it to a shop sounds to me like you have some bad problems going on inside their
Reply With Quote
  #6  
Old 03-13-2010
--weezl--'s Avatar
Member
iTrader: (1)
 
Join Date: Sep 2009
Location: Calgary AB, Canada
Posts: 3,139
im still reading what i said... i think it's probably the valve body (but i will admit i don't know much about automatic transmissions)

i still say it's a thermostat issue, radiator cap could be problematic too though
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP! Transmission Problems 4R44E 2000 Ranger 4x4 3.0 Flex Fuel Router 2.9L & 3.0L V6 Tech 2 05-05-2013 10:03 PM
2000 Ford 2000 Ford Ranger XL (Regular Cab step-side) - $3,295.00 ionspeedracer Ranger Based Vehicles 0 02-21-2011 03:45 PM
2000 4.0 4x4 auto help mjpff Drivetrain Tech 2 03-14-2010 08:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.