5 speed auto problems - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-11-2010
Member
Thread Starter
iTrader: (5)
 
Join Date: Jun 2009
Location: Beaumont, CA
Posts: 632
5 speed auto problems

So my transmission has been giving me more problems recently where before it was every now and then. It wont shift out of first and when it does, it shifts HARD into 2nd and 3rd while the "O/D off" light flashes. Any idea whats going on here?

Reply With Quote
  #2  
Old 07-11-2010
Tys 4x4 FTW's Avatar
RF Veteran
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
OD off light flashing deff means you has an issue in your trans. what the issue is, i cannot tell you. good luck!
Reply With Quote
  #3  
Old 07-11-2010
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
my 99, something to do with fluid pressure or whatever, the 2nd gear stopped working and it would have to skip over it. It pretty much drove okay but was jerky when having to skip the gear and we eventually took it to ford to get fixed.
Reply With Quote
  #4  
Old 07-11-2010
Member
Thread Starter
iTrader: (5)
 
Join Date: Jun 2009
Location: Beaumont, CA
Posts: 632
Aaron, any idea what they fixed?
Reply With Quote
  #5  
Old 07-11-2010
KLC's Avatar
KLC KLC is offline
RF Veteran
iTrader: (29)
 
Join Date: Nov 2007
Location: New Mexico
Posts: 13,115
Probably is the transmission solenoid.
Reply With Quote
  #6  
Old 07-11-2010
Member
Thread Starter
iTrader: (5)
 
Join Date: Jun 2009
Location: Beaumont, CA
Posts: 632
Another vid, got a cel this time

YouTube - July 11, 2010 1:42 PM
Reply With Quote
  #7  
Old 07-12-2010
Member
Thread Starter
iTrader: (5)
 
Join Date: Jun 2009
Location: Beaumont, CA
Posts: 632
Scanned the code...got P0720 Output Speed Sensor Circuit Malfunction...will have yo remove it and troubleshoot.
Reply With Quote
  #8  
Old 07-12-2010
tractorman's Avatar
Member
 
Join Date: Nov 2009
Location: Wisconsin
Posts: 190
I would check the valve body gasket. I haven't had to replace it, but from what I've read its problematic.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
5 Speed Auto with Overdrive feels like a 6 speed? patkelly1336 Drivetrain Tech 7 10-06-2012 09:04 PM
Speed sensor plug for a 5-speed manual BlackRanger04 Drivetrain Tech 4 01-04-2011 01:07 AM
1st to 2nd on 5 speed auto vinnysranger Drivetrain Tech 0 02-11-2008 07:12 PM
Who wants some more pep in their 4-speed auto? Needforspeed3685 General Ford Ranger Discussion 9 04-07-2007 07:50 PM
Auto or 5 Speed? UnlikelyHero 4.0L OHV & SOHC V6 Tech 13 02-14-2007 03:19 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.