Any problems with my swap? - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-21-2007
sniper_101's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
Any problems with my swap?

I need to check something with you guys (the experts) before I do this:

I have a 94' Ranger, ex cab, 2WD, 14" rims, 27" tires, automatic, 3.0L, had a 7.5" 3.73s L/S.

What all parts are required to put a 2003 or 2005 "8.8" ring gear, 10" brakes, 4.10 ratio, FX4 (locking), w/o Level II"

Will my rims fit? Will my parking brake work? Will my spring perches work? Will my U-bolts work? Will my ABS interfer (my RABS module doesn't work anyway)?

I searched for the past 2 hours and didn't find the exact answers I need for tomorrow.

If you guys could help me out any way you can it's GREATLY appreciated!
Reply With Quote
  #2  
Old 02-21-2007
pushdeck's Avatar
Member
 
Join Date: Oct 2005
Location: Melbourne, FL
Posts: 217
Far as I know nothing changes, but could be wrong, I went from 7.5 3.73 on my 3.0L to a 8.8 4.10LS off a 2000somthin and Im a 99, but far as I know, the axle has not changed, mabye the electronic connection, but I think your fine just using old yoke and connection and leaf and all, should bolt right up man. Wheels too...........
Reply With Quote
  #3  
Old 02-22-2007
sniper_101's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
How can I tell without ripping it apart if it is a 28 or 31 spline?? I want a 28 spline to make this easy as possible. Thanks guys!
Reply With Quote
  #4  
Old 02-22-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
if you get a 28 spline, then it will bolt up directly and nothing changes.......you can tell the 28 spline because it will be in all rangers except for the FX4 Level II's....
Reply With Quote
  #5  
Old 02-22-2007
sniper_101's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
Thanks for all the help guys, I probably should have searched but I was in a mad rush. I have a 04' 8.8" L/S 4.10 28 spline with 27,000miles coming this afternoon so I'm in a great mood. I just hope the bearings and everything are all good inside, shoudl have it running tonight or tomorrow

Thanks again!!
Reply With Quote
  #6  
Old 02-22-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
if you are going to be inside the axle, then go ahead and change the bearins, and axle seals....if you are not going to be in the axle, then dont worry about it because they dont have that many miles on them...
Reply With Quote
  #7  
Old 02-22-2007
sniper_101's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
Thanks for the tip, I might do all that while it's out, just to be safe. Thanks for the help!
Reply With Quote
  #8  
Old 02-23-2007
sniper_101's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
Ok I got the axle, painted it and popped the cover to find this:

Now I don't know much about axles but this is NOT a Limited Slip is it??

Name:  HPIM2508.jpg
Views: 4
Size:  117.2 KB

The sticker on the axle says V330L, it's an 8.8" 4.10 gearing, is this an open diff or am I losin my mind ? Thanks guys, man this pisses me off!
Reply With Quote
  #9  
Old 02-24-2007
5speedin2.3's Avatar
Member
 
Join Date: May 2005
Location: Livonia, Mi
Posts: 12
hrm, that looks like an open diff to me.
hold the drive shaft so it cant turn, then turn the wheel and check what way the other side turns, if it turns the other way, then its an open, if it turns the same way, its a limited slip.
this is what the 8.8 ls looks like.
Reply With Quote
  #10  
Old 02-24-2007
sniper_101's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
Aww hell, figures. Thanks for the help, ohh and what's it mean if my old 7.5" L/S's wheels turned opposite ways with driveshaft locked? I KNOW it was a L/S . . . is that wear?
Reply With Quote
  #11  
Old 02-24-2007
Member
 
Join Date: Nov 2005
Location: Avon, IN
Posts: 756
yep..
Reply With Quote
  #12  
Old 02-25-2007
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
also, i dont believe your rims will fit on the new axle, the center hole on the 14 inch rims is smaller than the newer axle shafts, you can either swap the axle shafts from your 7.5 into the 8.8, or get some other rims for it if this is the case. i know my 14 inch rims from my 94 dont fit on the '02 axle I have now. the center hole in the rims is too small and wont fit over the center of the axleshaft.
Reply With Quote
  #13  
Old 02-28-2007
sniper_101's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
OK problem, I got a different 8.8" installed, Limited Slip and what feels like 3.73 gearing.

There is a knocking/clunking noise coming from the rear axle, and my friend (who was outside) said it's coming from the right rear. I got out and grabbed the top of the tire and pulled in and out and it moves ALOT! There is also a ticking noise I can hear from the axle with the windows down, what could be the problem?

It vibrates really bad at some speeds and will shift somewhat rough once in a while.
Reply With Quote
  #14  
Old 03-01-2007
blackbetty's Avatar
Member
 
Join Date: Nov 2006
Location: aurora, ontario, CANADA
Posts: 904
ITS A BOMB!!!!! lol jks, how far in/out does it move? could be that your missing a c-lip, usually there is a little give back and forth but sounds like u have a lot of it.
Reply With Quote
  #15  
Old 03-01-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
you have a c-clip off and if you are not carefull, you will destroy your diff with that moving around in there.......and you will destroy your truck if you drive like that since your tire will come off....axle and all...
Reply With Quote
  #16  
Old 03-01-2007
blackbetty's Avatar
Member
 
Join Date: Nov 2006
Location: aurora, ontario, CANADA
Posts: 904
if im not mistaken (i swapped my axle out in the summer) if u dont have a c-clip in there the whole axle could slide out while driving...and yea you know the rest.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2005 Ranger Drivetrain Problems.... Pictures... Any idea what this may be? nross Drivetrain Tech 8 05-01-2009 09:19 PM
Any word on whipple or Any other Brands? j18willis Forced Induction & N20 Tech 2 10-08-2006 09:38 PM
Fabtech suspension lift W/ PA Bodylift any Problems? Greaseball_32 Suspension Tech 19 01-25-2006 09:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:13 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.