Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Bad tranny fuild???

  #1  
Old 03-27-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
Bad tranny fuild???

Today when leaving work i went to back up and i noticed that it took a sec for it to ingage reverse and when it did it felt like some on smacked the front of my truck and then i put it in drive no problem it ingaged almost instantly but then it shifted in to second really hard and the same when it shifted in to third but forth and fifth gear it was perfectly fine. I check all the fuild and it was where it should be and looked at the trans and its not leaking. I just had the brakes done and new u-joints put on saturday and had them drive it around to make sure everything was working right and they said that its fine and when i drive it home it was fine the only vibrations i was getting was because my tires arent balanced. And it drive fine on the way to work and when i went to lunch but started acting up when i went to leave work. Its almost like the problem ford had when the put the wrong fuild in from the factory and i am wonder if the place that i had my trans fixed a few months ago did the same thing by putting in that crappy fuild and all the sudden its acting up. The place that did the brakes cut me on hell of a deal on that so i called them on the way home from work and they said they would look in to flushing the trans but they had to order the kit. Do you guys think that if i put that lucus trans additive would be safe until i can get it flushed i just dont want to put something in there that will f-it up and cause it to blow out.
 
  #2  
Old 03-27-2006
a311fanam's Avatar
Member
Join Date: Dec 2004
Location: Westerly, RI
Posts: 2,006
how many miles do you have
 
  #3  
Old 03-27-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
i am just under 54000 miles. i am wishing i could afford to get rid of this thing for a new or different one with out problems like this one. this would be the forth fluid change in the tranny. first at 15000 for dip stick fitting cracking and falling in then again at around 30000 and again at around 40000 because the tranny gave way. The only problems i mainly have is with the tranny of course some little things here and there that wear out but its not like i am beating the living **** out of it.
 
  #4  
Old 03-27-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
I dont get it i went to go to murrys to look at some stuff and got pissed off and started beating the living crap out if it and it shifts fine afterwards if i get it to shift around 3k its fine anything lower and it shifts hard and slow.
 
  #5  
Old 03-27-2006
NicksterSVT's Avatar
Member
Join Date: Apr 2005
Location: NC
Posts: 1,955
sounds like you need a valve body
 
  #6  
Old 03-27-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
I hope to find out saturday when the guy drains it whats wrong with it. I can only think how much its going to cost to replace the valve body as long it can last another month i will be happy.
 
  #7  
Old 03-27-2006
NicksterSVT's Avatar
Member
Join Date: Apr 2005
Location: NC
Posts: 1,955
Originally Posted by 04edge
I hope to find out saturday when the guy drains it whats wrong with it. I can only think how much its going to cost to replace the valve body as long it can last another month i will be happy.

If you would like to upgrade, I offer a valve body replacement. PM me after you find out whats wrong with it if you are interested.
 
  #8  
Old 03-28-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
I let you know whats wrong when I find out nick. It seems to been alot better now that i was able to finally get my tire pluged and get that stupid looking spare off the rear today. It still is shifting like crap in 2nd gear if i am light on the pedal but the guy wont be able to look at it until next week some time now. I think i am just going to spend the 10 bucks and get some lucus trans fix until then and hope that it doesnt **** it up anymore than it already is.
 
  #9  
Old 03-28-2006
67cobain94's Avatar
Member
Join Date: Jul 2005
Location: Vero Beach, Florida
Posts: 708
Originally Posted by 04edge
I let you know whats wrong when I find out nick. It seems to been alot better now that i was able to finally get my tire pluged and get that stupid looking spare off the rear today. It still is shifting like crap in 2nd gear if i am light on the pedal but the guy wont be able to look at it until next week some time now. I think i am just going to spend the 10 bucks and get some lucus trans fix until then and hope that it doesnt **** it up anymore than it already is.
That Lucus stuff is junk. I hate to be the bearer of bad news. It's so useless it will void warranties now because it just swells up the seals. It does sound like a valve body problem. I can't see bad fluid or a transmission flush making your symptoms better honestly. Everytime we see something like this at work 99% of the time it's an actual problem. I had the problem with 2nd gear hard upshifts and replaced the valve body under warranty when I worked for Ford and it helped dramatically but it's still noticeable at full throttle that it snaps into gear there.
 
  #10  
Old 03-29-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
does any one know how much new valve body runs?
 
  #11  
Old 03-29-2006
a311fanam's Avatar
Member
Join Date: Dec 2004
Location: Westerly, RI
Posts: 2,006
dont quote me on this, but a few years ago i had a valve body changed on my old truck. They also flushed the tranny fluid and replaced something else. All i can remember was i paid well over $1500. i guess the valve body is a big job, it was 8hr worth of labor also.
 
  #12  
Old 03-29-2006
NicksterSVT's Avatar
Member
Join Date: Apr 2005
Location: NC
Posts: 1,955
Originally Posted by 04edge
does any one know how much new valve body runs?

I sell the upgraded valve body with the re-calibration system for 325 plus shipping(i think there is a 200 refundable core charge on them). This not only will correct the shift pattern, but apply a slightly larger amount of pressure to the clutches for longer life and firmer shifts.
 
  #13  
Old 03-29-2006
67cobain94's Avatar
Member
Join Date: Jul 2005
Location: Vero Beach, Florida
Posts: 708
Valve bodies aren't hard. Not 8 hours of labor hard at least. It's not 8 hours to R&R a transmission in a Ranger.
 
  #14  
Old 03-29-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
Nick is it 325 after the 200 core refund or is it before. Because if thats before i think come may i might order it and put it in but i really cant afford anything right now i need to say every penny i get to pay my income tax come april 17. I just hope it doesnt die by then but i dont think it will everything seems to be working fine now but one never knows.
 
  #15  
Old 03-30-2006
NicksterSVT's Avatar
Member
Join Date: Apr 2005
Location: NC
Posts: 1,955
Originally Posted by 04edge
Nick is it 325 after the 200 core refund or is it before. Because if thats before i think come may i might order it and put it in but i really cant afford anything right now i need to say every penny i get to pay my income tax come april 17. I just hope it doesnt die by then but i dont think it will everything seems to be working fine now but one never knows.
The 325 is not including the 200 refundable core. I have to charge the core charge because the v/b manufacturer charges me this until I return a v/b.
 
  #16  
Old 03-30-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
i might order it in may when i actaully will have money again. But on the good side i finally found out whats been make this strange noise from the back. After taking it to a bunch of places and no one knowning what it was i got home from work early today and just happened to look above the muffler and notice that the heat shield was falling off and hitting the muffler and the shield above where the tail pipe goes over the axel also was falling off so i just duck taped it up. But tomorrow i going to get some spray adhesive and glue it back up.
 
  #17  
Old 04-12-2006
04edge's Avatar
Member
Thread Starter
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
I finally get it fixed. I had them flush the tranny since they were in there and it turned out to be ok They checked the u-joints and turns out the rear one broke so they had to put a new one in again 230 bucks later it drives like a champ. Now to do something about the tires.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Draimen
Drivetrain Tech
2
09-03-2016 10:35 AM
LayingFrame89
Ranger Products, Company, & Member Reviews
34
12-01-2007 06:59 AM
ranger
General Ford Ranger Discussion
32
07-31-2007 11:50 AM
FMD
General Ford Ranger Discussion
13
04-25-2006 07:21 AM
PickupMan92
General Technical & Electrical
4
07-31-2004 10:41 PM


Thread Tools
Search this Thread
Quick Reply: Bad tranny fuild???


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.