Broken AVM Hub - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-12-2012
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
Broken AVM Hub

I installed a new front axle with 4.88 gear and an ausie locker. I bought some used AVM hubs a couple years ago and havnt had any trouble with them. Everything was fine when I still had the 31 inch tires on. I put on some used 33's and am having trouble getting them ballanced. They still shake some. The hubs were working loose and every time I would get some where i would have to push them back on. When the hubs where locked in the locker does a lot of clicking when turning. Well yesterday I decided to take the hubs off and see what was going on. when i too the passeger hub off only half of it came off. So one of the hubs has broke. I put the PVH hubs back on and so far they havnt came loose. I know the hubs are known for breaking. Do you guys think it was just the hub going bad or the locker that caused it to break since the hub would be the weak point in the front drive line?

Pics of the hub


Attached Thumbnails
Broken AVM Hub-2012-11-12_09-43-20_471.jpg   Broken AVM Hub-2012-11-12_09-42-52_844.jpg   Broken AVM Hub-2012-11-12_09-42-41_888.jpg  
Reply With Quote
  #2  
Old 11-12-2012
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
wheres the orange lock ring? I'm going to say it was the hub and not the locker. It shouldn't cause them to break. quite a few ppl have run an aussie and had no issues.
Reply With Quote
  #3  
Old 11-12-2012
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
i had AVM's an aussie and 33s and never had one single problem with them...
Reply With Quote
  #4  
Old 11-12-2012
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
Quote:
Originally Posted by 99offroadrngr View Post
wheres the orange lock ring? I'm going to say it was the hub and not the locker. It shouldn't cause them to break. quite a few ppl have run an aussie and had no issues.
What orange lock ring?

Ok sounds like just a problem with the hub, probably from them working lose. I guess ill have to save up for another set. The PVHs will work for now i guess unless i have a vacume issue.
Reply With Quote
  #5  
Old 11-12-2012
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
Justin, does your aussie click when the hubs are locked in but the truck is in 2wd while turning?
Reply With Quote
  #6  
Old 11-15-2012
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
bump
Reply With Quote
  #7  
Old 11-19-2012
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
Quote:
Originally Posted by littlered View Post
Justin, does your aussie click when the hubs are locked in but the truck is in 2wd while turning?
Yes, that is normal...when there is no torque on the pinion, the locker will ratchet...the orange ring holds the cv axle thru the hub bearing before the lock out hub goes on...it is an orange snap ring
Reply With Quote
  #8  
Old 11-19-2012
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
So the ring isnt part of the AVM hub its part of the truck? There is a white plastic snap ring that holds the cv axle in the hub bearing, but it doesnt come out with the hub.
Reply With Quote
  #9  
Old 11-19-2012
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
that is probably it...it is not part of the hub...it is usually painted orange but it may have flaked off
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How To: AVM Hub Install Version 1 Biz Engine & Drivetrain 28 12-20-2008 11:51 PM
AVM Hub Lockers Alex98 Drivetrain Tech 55 12-15-2008 07:55 PM
Avm Manual Hub Install Help!!! huggyjd Drivetrain Tech 10 03-22-2008 08:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:29 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.