New clutch installed but now does not disenguage! - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-21-2010
torchedranger's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: VA
Posts: 159
New clutch installed but now does not disenguage!

Ok so i just yanked the trans out of my ranger because it needed a clutch. So i put one in and reinstalled everything 2 day, now the clutch will not disengauge. Its a 1999 2.5 single cab short bed ranger with 208k miles on it. I changed the throw out bearing,clutch and pressure plate. I had to remove the hydraulic line to pull the trans, does it have to be bled after i did this because my buddie has the same truck and he didnt have too. But im just stuck because i dont have a truck to drive and i put everything back together and and put new fluid in the trans. HELP PLEASE!!!!

here is some pics of the truck

Name:  Pics032.jpg
Views: 4
Size:  172.8 KB

Name:  Pics033.jpg
Views: 4
Size:  198.2 KB

Name:  Pics036.jpg
Views: 3
Size:  135.1 KB

Name:  Pics037.jpg
Views: 3
Size:  172.4 KB
Reply With Quote
  #2  
Old 02-21-2010
ranger05's Avatar
Member
 
Join Date: Jun 2009
Location: grand rapids michigan
Posts: 178
yes it has to be bled. your going to want to search on how to do it cause from what i hear its not the easiest to bleed.
Reply With Quote
  #3  
Old 02-21-2010
Lord Of War's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2006
Location: Thornton, Colorado
Posts: 4,599
There is a great youtube vid. Let me find it for you.

Here is the vid.

http://www.youtube.com/watch?v=HgNTDGwcjZc
Reply With Quote
  #4  
Old 02-21-2010
torchedranger's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: VA
Posts: 159
yeah ive heard the same thing
Reply With Quote
  #5  
Old 02-21-2010
torchedranger's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: VA
Posts: 159
SWEET MAN!!! Im going out to the garage to try it out and let you guys know how it works out
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
clutch pedal soft and does not engage tranny grinding noise k00kiem0nster SOHC - 2.3L & 2.5L Lima Engines 9 06-01-2014 02:00 PM
New Member - Wrong Clutch! Possible to put 4.0L v6 clutch on 2.3 4cyl w/ new flywheel DJDev Drivetrain Tech 2 10-28-2012 09:41 PM
Ranger engine cuts out over bumps, but electrical does not lose power. atmu5fear General Technical & Electrical 3 11-28-2011 10:11 PM
Installed HID lights in headlamps but now my fog lights will not work BmillerEdge General Technical & Electrical 1 12-29-2010 10:37 AM
Not 1, Not 2, but 3 broken CV's!! HAHA! rngprerunner Drivetrain Tech 12 12-07-2008 10:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:20 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.