No drive to my front wheels while under load and making a grinding noise - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-24-2013
Member
Thread Starter
 
Join Date: Jun 2013
Location: Emerald, Queensland
Posts: 1
Icon4 No drive to my front wheels while under load and making a grinding noise

My 2011 xlt ford ranger has lost drive to thefront end when under load (going up hills and through mud) and is making a grinding noise aswell anyone know what might be causing it. Could it be my selector or have I done something to the front diff?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
3.0 ticking noise under load Kris03 2.9L & 3.0L V6 Tech 0 05-19-2012 07:39 PM
Squealing/sqeaking noise, very high pitched and varies under load 1996DangerRanger General Technical & Electrical 7 12-04-2011 03:50 PM
Breaks making a grinding noise, good pads evilclown312 General Technical & Electrical 14 02-14-2011 04:45 PM
rattling noise b/w 2k and 4k rpms under load? Edge of Darkness 4.0L OHV & SOHC V6 Tech 12 04-20-2006 08:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.