Trans or Rear End Problem - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-25-2011
bravetitan24's Avatar
Strokin'
Thread Starter
iTrader: (3)
 
Join Date: Jun 2010
Location: Haughton, LA
Posts: 2,156
Icon5 Trans or Rear End Problem

I'll go ahead and start this from the beginning. I put a lift and 33s on my truck back in August. I have a 7.5 and 3.73s so I knew that I'd probably end up having to replace the axle eventually. I'm hoping that's the solution to my problem.

When leaving my friend's house about a 10 days ago, my truck made a strange noise and "bucked" a little when I shifted into reverse from park. I guess a loud click is the best way to describe it. I was hoping that it was just a one-time thing, but it still hasn't gone away. It feels and sounds like the problem is at the axle, but I can't confirm that. It doesn't happen when going from drive to reverse.

A few days later, I noticed that my truck was having some trouble shifting gears, but only after I get above 45mph or so. It will eventually shift, but it takes longer than usual and it revs pretty high before it shifts. My transmission went out about 2 and a half years ago, and I had it rebuilt. Back when that happened, I had trouble getting through my gears, but it was bad through all of the gears, and my O/D Off light was constantly flashing. Now it only happens in the higher gears and isn't nearly as consistent. The O/D off light isn't on now either.

So my question is, can any of you guys point me in the direction of what exactly my problem is? I hope it's just the rear axle and not the transmission since it would be much cheaper to replace. Sorry to make this so long but I'm trying to give y'all as much information as possible. Truck is an 02 Edge with a 3.0 and auto. There's about 103k miles on it.
Reply With Quote
  #2  
Old 02-25-2011
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
when my 7.5 started goin out it started to whine and it never bucked or had trouble shifting...
Reply With Quote
  #3  
Old 02-25-2011
bravetitan24's Avatar
Strokin'
Thread Starter
iTrader: (3)
 
Join Date: Jun 2010
Location: Haughton, LA
Posts: 2,156
Wirelessly posted

I haven't heard any whining from it. I just drove about an hour on the interstate and in town and it did just fine. No trouble shifting at all. I'm on break from school for the next few days so I'll keep monitoring it and see what happens. I'll probably go ahead and start looking for an 8.8 since I'll end up needing it anyways.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Nasty Noise from the rear end/ rear end acting weird stephen.g.fiddes Drivetrain Tech 30 05-02-2010 07:57 PM
Nasty Noise from the rear end/ rear end acting weird stephen.g.fiddes Drivetrain Tech 0 04-27-2010 06:33 PM
front end done, rear end to go quicksilver2001 Drivetrain Tech 2 03-14-2008 06:51 PM
can i use the stock trans and rear end 00xlt4x4 8-Cylinder Tech 4 09-05-2007 07:51 AM
Huge Problem with rear end JASONGR81 Drivetrain Tech 23 01-19-2007 12:26 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:15 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.