Weird clutch issue...any ideas? - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-14-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: Bayonne
Posts: 44
Weird clutch issue...any ideas?

Hello gentlemen...was wondering if you could give me any ideas on what going on. I have a 96 ranger xlt 5spd 6cyl with about 124000 miles. I purchased about 2 months ago. Supposably the clutch was just redone and showed no signs of giving out. No slippage or anything. It is a cable clutch the grabbed rather high to engage wich i got use to.

Yesterday at a red light i noticed the pedal would not come of the floor and would not let me take it out of gear but i somehow managed to get it out and driving continued normally with no flaws. Took it home and parked it and all was fine. Now this morning i put it in reverse and the same thing happened to where she stalled out. I restarted it and again everything seems fine with the exception of it engaging almost at the bottom of the pedal. All shift seems fine...no slippage what so ever. Any ideas on whats going on. Could it be the cable or clutch assembly itself? Any help is appreciated.

Last edited by skillzo1; 05-14-2011 at 06:28 PM.
Reply With Quote
  #2  
Old 05-14-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
how many miles are on the truck
Reply With Quote
  #3  
Old 05-14-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: Bayonne
Posts: 44
124000
Reply With Quote
  #4  
Old 05-14-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
search slave cylinder
Reply With Quote
  #5  
Old 05-14-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: Bayonne
Posts: 44
Will do thank u
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Possible Clutch Problem. Any Ideas? susieranger General Ford Ranger Discussion 3 09-09-2011 05:43 AM
Weird electrical issue uhittheuglytree General Technical & Electrical 2 02-19-2010 03:07 PM
Weird Air Conditioning Issue...Help Prerunner-Ranger General Technical & Electrical 21 08-16-2008 10:04 AM
Weird overheating issue RANGERMAN66 4.0L OHV & SOHC V6 Tech 5 12-08-2007 06:34 PM
Clutch is getting stiffer - any ideas?? Scott.E.Dont Drivetrain Tech 2 08-15-2007 08:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.