01 Mazda B3000 3.0 won't start, no fuel to rail - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-28-2013
geo geo is offline
Member
Thread Starter
 
Join Date: Oct 2013
Location: Stafford VA
Posts: 2
01 Mazda B3000 3.0 won't start, no fuel to rail

Hi all, this is my first time posting here but these forums have been very helpful to me in the past. Forgive me if I'm asking questions that have already been answered.

I have an 01 Mazda B3000 with the 3.0/auto. I had it out yesterday and it was running great, stopped by a friend's for a few minutes and when I came out it would crank but not start. It did sputter a few times but nothing else, so it appears I have spark.

What I've done so far - checked the fuel pump fuse with a meter, it's good. I can hear and feel the fuel pump relay when I turn the key to the run position, but can't hear the fuel pump at all. I didn't have a pressure gauge but I pressed the valve on the fuel rail there was pressure there initially but after I let that out it never pumped back up (pressing the valve again there was nothing). The inertia switch was not tripped. Waited a couple hours and tried it again - no change. Disconnected the battery for about a half hour, no change. My wife said she had trouble starting it once the day before but then it started and was fine til yesterday.

Seems to me it would have to be the pump, but wanted some other opinions if possible.
Reply With Quote
  #2  
Old 10-28-2013
02slammedranger's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2009
Location: Dearborn, MI
Posts: 593
try and turn the key to the run position a few times... something like 3 or 4 times then try and start it. my 01 did the same thing. the pressure line would leak all the pressure out after a few mins. so doing that is like a choke style thing. if it starts then you need a new pump. also check your gas filter
Reply With Quote
  #3  
Old 10-28-2013
geo geo is offline
Member
Thread Starter
 
Join Date: Oct 2013
Location: Stafford VA
Posts: 2
Yeah, tried the key dance with no luck. I haven't crawled under there yet to make sure there is power to the pump so I guess thats my next step
Reply With Quote
  #4  
Old 10-28-2013
02slammedranger's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2009
Location: Dearborn, MI
Posts: 593
yeah if there is power try hitting the tank with your hand if the pump starts it a bad connection in the pump.
Reply With Quote
  #5  
Old 11-08-2013
Member
 
Join Date: Aug 2010
Location: Round Rock
Posts: 484
The bad news is your fuel pump is out. The good news is is that it is easy to replace and not very expensive. Just search out fuel pump.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mystery gasket for fuel line to fuel rail connector cjthom1728 SOHC - 2.3L & 2.5L Lima Engines 1 10-22-2014 01:28 PM
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
how wide? from bed rail to bed rail? Tys 4x4 FTW General Ford Ranger Discussion 14 03-25-2009 10:47 PM
1994 Mazda B3000 4x4 SE knocking noise Jordan94 2.9L & 3.0L V6 Tech 4 08-29-2007 05:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:02 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.