General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

92 Danger Ranger v6 3.0l running rough

  #1  
Old 02-19-2013
Member
Thread Starter
Join Date: Feb 2013
Location: Lakeland
Posts: 1
92 Danger Ranger v6 3.0l running rough

Started running rough, replaced plugs, wires, button and cap. Still running rough, made sure timing was right. Still running rough, checked to see what code puts out. Comes up as 512 ECA problem, Keep Alive Memory test failure. Unhooked battery to clear code but comes up the same code. I have one person saying a motor mount is busted causing the timing not to set. Then I have another person saying a tranny mount is busted causing the rough idle. I don't know what the problem is, I just want my truck fixed. About a year ago the computer under the dash was replaced along with the distributor. I am a female but I do know about some stuff and I have a book for my truck. But at the moment I am stuck. Please Help.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ChargerOnDavins
2.9L & 3.0L V6 Tech
3
03-23-2015 03:25 PM
drumz
SOHC - 2.3L & 2.5L Lima Engines
2
05-29-2012 01:22 PM
bonecrusher
SOHC - 2.3L & 2.5L Lima Engines
3
03-19-2011 04:04 AM
mykacie
General Ford Ranger Discussion
13
12-09-2010 08:07 PM
IBleedBlue331
General Technical & Electrical
8
11-30-2010 05:53 PM


Thread Tools
Search this Thread
Quick Reply: 92 Danger Ranger v6 3.0l running rough


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.