Ac problem. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-26-2016
Member
Thread Starter
 
Join Date: May 2016
Location: Fort Pierce, Fl
Posts: 1
Ac problem.

I have a 99 ranger an the a.c. fan speed switch isn't working besides the last speed. The first 3 speed dont work. Any idea what it is. A.c. blows ice cold etc. Started lastnight the issues.
Reply With Quote
  #2  
Old 05-26-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,577
Welcome to the forum

Most common reason for only high speed on blower motor is failed Resistor block on the motor housing, or corroded connectors on the blocks plug in.
Resistor block costs $10-$25 depending on year

Video here: www.youtube.com/watch?v=BQ1j98NVgjk

Other place it can fail, but less common, on the back of the fan switch in the cab panel, remove panel and have a look for melted wires on the switch.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 06:58 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:33 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.