A/c compressor not getting any power - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-21-2009
blueranger789's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
A/c compressor not getting any power

Ok as the title say my a/c isnt getting getting cold due to the fact that the compressor isnt comeing on. found out buy running wires directly from the battery that the compressor is fine and just isnt getting power. anybody got any ideas as to what my be the problem?
thanks for any input.
Reply With Quote
  #2  
Old 08-21-2009
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Check to ensure you have proper refrigerant charge in system. If properly charged check the following:

Fuses:
F2.19 (25A) CJB
F1.7 (30A) BJB
F1.25 (10A) BJB

Relays:
PCM Power Relay BLB
A/C Clutch Relay BJB

Switches:
A/C compressor cycling switch Low pressure line P/S by receiver dryer
High pressure switch 3.0L High pressure line D/S near battery, 4.0L High pressure line D/S behind compressor

.
Reply With Quote
  #3  
Old 08-22-2009
SB05EDGE's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2007
Location: Midland, Texas
Posts: 534
best way to see if the electrical part of the a/c is fine is to jump the wires together at the cycling switch, if all is ok, the a/c compessor will turn on.
Reply With Quote
  #4  
Old 08-22-2009
quicksilver2001's Avatar
Member
 
Join Date: Dec 2004
Location: Opelousas, Louisiana
Posts: 704
is it full of freon?
Reply With Quote
  #5  
Old 08-22-2009
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
if the system is low on freon it want kick on
Reply With Quote
  #6  
Old 08-23-2009
blueranger789's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
oops sorry left out some info, yes its full of freon, actually overcharged


Quote:
Originally Posted by SB05EDGE View Post
best way to see if the electrical part of the a/c is fine is to jump the wires together at the cycling switch, if all is ok, the a/c compessor will turn on.
where is the cycling switch at(pics would be nice if anyone has some, htanks)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ac clutch not getting power millwright General Technical & Electrical 7 06-16-2011 06:58 AM
New member...Not getting power to fuel pump--87 2.9l cyrusb06 General Technical & Electrical 3 01-20-2011 03:25 PM
Fuse not getting power! [pleas help asap] aaron_ariens General Technical & Electrical 14 12-06-2009 01:05 PM
Air conditioning compressor does not work CAG General Technical & Electrical 4 07-03-2009 08:32 AM
not getting any heat bpolly_2004 General Technical & Electrical 4 12-29-2007 08:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.