A/C Issue Maybe - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-24-2011
Z7What's Avatar
Member
Thread Starter
 
Join Date: Dec 2010
Location: New Orleans
Posts: 306
A/C Issue Maybe

My A/C system isn't blowing like it used to out the vents. The fan is blowing like before but the air output out the vents doesn't seam to be as much as before. Anything I can look into?

Wayne
Reply With Quote
  #2  
Old 08-24-2011
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Is it blowing out the defroster?
Reply With Quote
  #3  
Old 08-24-2011
Z7What's Avatar
Member
Thread Starter
 
Join Date: Dec 2010
Location: New Orleans
Posts: 306
No

Wayne
Reply With Quote
  #4  
Old 08-24-2011
fitsector's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2010
Location: Gto, MX
Posts: 369
I had a similar problem and had to dismount the turbine, discover trash and dry leafs from trees.

May help.
Reply With Quote
  #5  
Old 08-24-2011
Z7What's Avatar
Member
Thread Starter
 
Join Date: Dec 2010
Location: New Orleans
Posts: 306
Quote:
Originally Posted by fitsector View Post
I had a similar problem and had to dismount the turbine, discover trash and dry leafs from trees.

May help.
More details please. Pics? Location?

Wayne
Reply With Quote
  #6  
Old 08-25-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Remove the blower motor.It's located in the engine compartment on the passenger side on the firewall right next to the hood hinge. Round black thing.
The mounting screws are around it's circumference.
Reply With Quote
  #7  
Old 08-25-2011
fitsector's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2010
Location: Gto, MX
Posts: 369
Just like Ken Said. If you need any pics just ask and IŽll post them up !
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Pats key issue maybe?!? 04 2.3, 5speed 4x2 Vino634 General Technical & Electrical 0 06-22-2015 01:33 PM
Fuel Pump? Maybe? Maybe not? grrrrrrr mikewurtz General Technical & Electrical 3 03-01-2012 08:46 PM
01 XLT 4X4 Maybe/Maybe not! shagdue Drivetrain Tech 7 12-11-2011 10:49 AM
new guy with a couple electrical problems and maybe a mechanical issue and a couple bonzo 1 General Technical & Electrical 5 12-27-2009 06:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:26 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.